Wyze Cam Outdoor not charging

Just yesterday night, I was given a Wyze Cam Outdoor that was left in an attic. I go to my room and charge it, and it did show a solid red light for a brief second. Then, the light disappeared and never showed up again. The Base Station was connected to our router but still no signs. On one hand I believe that the charging port is messed up but I can’t clearly see it. I was even using the right power cord! I left it charging overnight but when I came to turn it on today, it still didn’t work. At this point, I’m starting to lose hope for this camera and eventually call it “useless”.


Are you charging it from the USB port on the base station?

Since that initial red light, are you able to get any other status lights out of it, or even the red one anymore? What if you turn the camera off or on?

1 Like

I have tried charging it in other areas than the Base Station, but there was still no light. And yes, I have tried turning it off and on or just pressing the sync button anyways.

Thanks for your support though!

If there’s no light at all when plugging it in, I’m gunna guess it’s a hardware failure. If your still in warranty (1year) you can try and get a replacement, if not, there’s not much you can do.

You can wait to see if others have any ideas.

1 Like

I believe that it was charging already, but the light didn’t show up. Last night I stood in front of it for a couple of seconds and it turned its IR Night Vision lights on, and started flashing blue. I tried pressing the SYNC button to get it set up, but it didn’t say “Pairing is in progress, please wait.”.

I was given a working Wyze Cam Outdoor and I use it now.

Meanwhile, the other camera I’ll call “haunted”.

It randomly turns on at night and was solid yellow last time it turned on. I’ve put it in my cabinet where it will probably stay for the rest of eternity.

MOD NOTE: reference to new account deleted due to account merge. Reference to “other camera” here: Wyze Video Doorbell Pro not charging

1 Like