Wyze Cam Doesn't See Mobile Hotspot WiFi Name

I am trying to configure a Wyze Cam to use the mobile hotspot on my Android phone. The problem is that the name of the WiFi network is not being displayed in the Wyze app.

I know the hotspot is visible (and working) because the name shows in the list of available WiFi networks on other devices and I can connect to it. (iPad, laptop, etc.)

The Cam shows other 2.4G WiFi networks e.g. my home’s, my neighbor’s etc. It even shows a few “incompatible” 5G networks.

So, I know that the hotspot is working and I know that the Cam works on other 2.4G networks, but I can’t get the Cam to see the hotspot.

Does anyone know why it doesn’t see my phone’s WiFi hotspot name? Thanks!

Do you have your GPS location turned on?

Thanks for the response.

Yes, Location is turned on.

I tested it under “Allowed only when app is in use.” and “Allowed all the time.” Doesn’t work either way.

My phone settings show that the Wyze app accesses the Location services each time I try to connect the Cam.

Have you verified in your Hotspot settings that you have it set to show, WPA2-, and 2.4GHz AP?

I don’t use my Android hotspot and have never installed a cam to it so I’m not really sure how the cam reacts with the phone being the WiFi and using the app. I thought the list of WiFi in the install was populated from the phone access list which would be a problem if the phone was trying to access its own hotspot.

Have you tried to install the cam to your app\account using the iPad’s app while it is connected to the android hotspot?

Are you trying to setup the cam on the same phone as the hotspot is on? Not sure if that works, try setting it up on a diffrent device

1 Like

SlabSlayer: I will try to use the iPad app, but I won’t get to it until tomorrow.

IEatBeans: I hear what you are saying, but I don’t see why it wouldn’t work. Isn’t the list of WiFi networks shown during the install process coming from the Cam? Isn’t the Cam saying to the app “I see all of these networks. Which one do you want me to use?”

I believe the list of WiFi networks is coming from the phone. this is the reason the cam and the phone need to be on the same network to install. The cam gets the WiFi credentials from the phone.

Since the phone isn’t on its own hotspot, it won’t show that in its own WiFi list and the cam won’t install. The phone has to be logged into the hotspot first, which it can’t do if it is also the hotspot.

1 Like

Correct, the list of available WiFi networks is from your phone - not the camera.
Make sure the hotspot does not have special characters in the SSID. I ran into that when trying to set up a camera to use my &^%$#@ iPhone as a hotspot. The phone name was Jim’s iPhone. The Wyze camera could not take the apostrophe. Changed the name of my @#$%^& iPhone to Jims iPhone and the camera had no trouble connecting.

1 Like

SlabSlayer: I was able to connect the Cam to the hotspot by connecting the iPad to the phone’s hotspot and using the Wyze app on the iPad. After that, the Cam connected to the hotspot running on the phone. Thank you for that suggestion.


K6CCC: On my Android there are separate names for the phone and the hotspot.

The phone’s name is Derby’s S21. The hotspot’s name is Dave’s S21. I had no problem using Dave’s S21 as the WiFi name when setting up the Cam. The apostrophe and the space did not cause any issues.

Android does, iPhone does not.

I could not get the Wyze cameras to use an SSID with the apostrophe (may be firmware version related - it was a couple years ago).

1 Like

One other trick to keep in mind is just setting your hotspot to the same SSID and password as your regular home network. Then a relocated camera will *just work" off the hotspot. (But never turn that hotspot on when you’re actually home with it.)