Wyze Bulb connection problems

Does anyone seem to be having trouble connecting Wyze bulbs on iOS 14. It worked fine until we upgraded our phones now I can’t seem to get my bulbs working. I used to be able to set them all up and name them using the same lamp and then I’d move them to the light they’d go in but I can’t seem to be able to take the bulb out and move it once it’s set up in a specific socket.

I have had issues with Wifi and IOS 14, not with Wyze yet but with a different brand device.
Apple added a feature called Private Address to the Wifi settings, designed to enhance privacy in public networks. Good idea but the bad part is that it is turned on by default.
Don’t know if that’s your issue or not but try going to Settings/ Wifi and clicking on the info icon by your active wifi. Then try turning the Private Address button off.
Hope this helps!


I have the same problem with bulbs that won’t connect after upgrading to iOS 14

I was able to reconnect my Wyze cam and it seems to be working

I’ve had the same issues with the WYZE bulb and smart plug after upgrading to iOS 14. I’m hoping the folks at WYZE are working on fixing issues with the app.

I have a set of Kasa smart plugs and they were able to connect to the network. I’m guessing it’s at the app level where we are seeing this issue

Thanks for the update. I will post any resolution that I find. It appears to be a iOS problem and it is affection several of my other devices


Latest WYZE app update fixed the connection problem for me, but now the bulbs disconnects and doesn’t reconnect more frequently.

Update: I decided to disable Alexa skills and Google Home Assistant from WYZE and it looks like it’s more stable than before.

Another update: it could be a issue with communications beyond the control of the user. I’ve tried a separate virtual lan for wyze devices as well as different DNS servers. I’m still getting the disconnects and offlines.