Tip- iPhone (iOS 14 ) Turn off Private Address in WiFif settings to find Wyze Blub's Wifi!

I spent like 4 hours trying to setup my Wyze bulbs yesterday and finally figured out why it wasn’t working. Here is what was happening. When I was prompted to connect my iPhone to wyze_smartbulb_apxxx it never came up as an available network on my phone. Why? Because the new iOS has a new privacy setting in the iPhone’s WiFi called Private Address toggled to the “on” position. When it’s “on” it prevents access to certain wireless networks that require real MAC address. wyze_smartbulb_apxxx requires a real MAC address.

Read about it here: How to manage or disable MAC randomization in iOS and iPadOS 14 | TechRepublic


I’ve tried your suggestion and it still doesn’t work. Crazy thing is I can take another phone, log into my account, then add the device and it puts in my device group. I can then go back to my phone and it works. This is happening on the plugs too.

Just curious, what makes you think the Wyze bulb needs a real address?

Not sure what your question is?

I was referring to the original post. I have never had to turn off private MAC to connect any of the Wyze products, so I was wondering what led to the conclusion.