iPhone not finding the Wyze Bulb WiFi Network

Hi everybody. I am trying to set up a Wyze bulb. The instructions are very straight forward. I already use a few Wyze cams so I am familiar with the app. I clicked on add new device, flipped the light on & off 3 times, selected my network, here is where it goes south, when I’m prompted to connect my phone to the wyze_smartbulb_apxxx WiFi.

-My iPhone OS is 14.1.
-Turned cellular data off
-not using 5G

Hi @viavillalobos, could you explain what happens when you are prompted to connect your phone to the wyze_smartbulb_apxxx WiF? Thanks!

1 Like

Ok it says “connect your phone to the wyze_smartbulb_apxxx” then I click where it says “choose wifi” in the turquoise colored button at the bottom of the screen. It automatically takes me to the wifi settings on my iPhone, my iPhone starts searching for networks, a few pop up but not wyze_smartbulb_apxxx.

1 Like

I FIXED THE ISSUE. You have to toggle of “private addresses” in your iPhones Wifi setting. so go here> Settings/click on your wifi network/ toggle off private addresses. The aim of this feature is to protect users from being tracked while on public hotspots. And while the feature works as designed, it also has the added downside of limiting or altogether preventing access to certain wireless networks. This was the case when I was prompted to connect to wyze_smartbulb_apxxx. That specific network requires a true MAC Address,


Awesome! I am so glad you figured it out! :smile: