Wyze Battery Cam Pro Firmware Beta Test 9/28/2023


What’s New:

  • Added support for local microSD card recordings on Wyze Battery Cam Pro

  • Improved microSD card logs

  • Fixed a bug that caused Wyze Battery Cam Pro to sometimes go offline briefly after changing camera settings

  • Bug fixes


On a Battery Cam Pro with no MicroSD card installed, it still lets you turn on microSD card recording for events only or continuous.

iOS 17
iPhone 12 Pro Max
WyzeBeta: 2.46.0 (2)
Battery Cam Pro Log ID: Failed to submit 4 times over LTE and Wifi


Thank you @cyberdog_17! We’ll fix this before the official release.


Loaded and looking good so far under Android beta and production apps. Cam is plugged in 24/7, 128GB card installed, set to continuous recording. Verified cam is actually writing to SD continuously and is reviewable via the SD Card icon. Will test this setup for a 2-3 days (need to trigger some events) before switching to Events Only setting.


Installed and will begin testing. Being able to record to SD Card is a great addition.


On IOS app 2.46.0 (2) my BCP (as well as FLP, but no other cams) are only able to see 4 items in the menu. The SD card and siren buttons are missing. I am unable to scroll this menu side to side like I used to be able to.

1 Like

Not working at all for me on 2 battery cam pros.

Samsung Galaxy S22 Ultra (Android)

Hi @IEatBeans, I’m not able to reproduce this on my 2.46.0(2). I can see the SD card and siren buttons. Are you still seeing this issue on BCP and FLP?

1 Like

Hi @wotlos, from the screenshots, it seems like the camera wasn’t recording to the local SD card. Could you check if the following settings are set correctly?
1, Event Recording > Detect Motion needs to be turned on.
2. Advanced Settings > Record to SD card need to be turned on.

1 Like

@wotlos What are you using to get those call out message boxes? I like that.

1 Like

@WyzeLi , thanks for your reply. Yes, that would seem to be the case. I can assure you though, I’ve tried every combination of toggled settings imaginable, including those you’ve listed. I even tried setting up a brand new battery cam pro. I thought maybe it may have something to do with the device not wanting to record to the sd card unless it was formatted and installed after doing the firmware update, but no dice…

@Earl.Automation unfortunately it’s not a mobile app. I was just using ScreenRec. I simply take a screenshot on my Android device, which then syncs to a OneDrive folder, then I just open the image file on my PC and do a screen-grab with that program and add whatever to it. Kind-of a round-about way of doing it but I also do a lot of UAT for work and am used to using it.

1 Like

Yes I am still seeing this on those devices.

I’m not sure if it’s an app bug or a Battery Cam Pro bug but when setting the resolution to 2K and then leaving the app whether by force closing or leaving the stream and returning, it always defaults to HD.

iOS 17
iPhone 12 Pro Max

Could you send us an app log so we can take a look?

@cyberdog_17 I tried to reproduce this following your steps and I couldn’t repro it. Note that I clicked the Close button to save the settings. I’m on iOS 17 and iPhone 13 pro max. The settings are saved correctly.

If “Close” is not tapped after changing Recording Resolution, the change does not “stick” under iOS and Android. I’m not sure if that is cyberdog’s issue, but regardless, I’d suggest changing the word “Close” to “Save” for explicitness/clarity of action and term consistency across app. I.e., click “Save” for change to take effect.

1 Like

Hey sorry for the confusion. The recording resolution does stay at 2K for me. It’s the Livestream quality. The little box in the left hand corner of the screen where you can have, “auto” “HD” “2K”


Got it! It did show as Auto as default for me but once I changed it to HD/2K, next time I enter the livestream page, it’d remember the setting for me. We’ll fix the Auto resolution issue. It should be either defaulted to HD or user’s last changed setting.


Should I submit a log for the camera or “account and services”?