WYZE band no workie

My band un-paired a week or so ago and I submitted a ticket number 20981. Someone in the group helped me get it paired again and the band its self started working but it will not connect to blue tooth. So far I have

Rebooted the band
Reset the band to default
Removed the band from the app and tried to reinstall.
I have the code on the band but since it will not pair, I can go no further
Turned my phone off (not rebooted)
Turned my phone BT on and off, it finds the band but when I select it to pair, it just flashes pairing for a few seconds then the word “pairing” goes away and WYZE continues to show it is available to pair but it never does.

I have re-booted my phone, removed and paired other BT devices but WYZE wont do it.
I have the code on the band but since it will not pair, I can go no further
The cameras are working, just not the band

I cannot figure out how to go directly to customer support to check on my ticket ( and the log I sent them). Contacting customer support is painful, I dont like going thru all the hoops each time I need help. Maybe I am not trying to contact them the correct way

Band Version1.0.6.96
Android App Version V2.12.3, I just checked and there is no newer version available right now.

You’ve done a lot of steps alright. In all that, have you gone to Bluetooth in your device Settings and told the device to Forget the Wyze Band, then gone to your Band and tried to synch? That for me is the magical step.
Plus-be sure your Band has not paired with another nearby device.
As far as Support is concerned, I have had the best experiences via phone support.
Live support is available:

Monday - Friday 5 am - 6 pm PT

Saturday 8 am - 4 pm PT

Thank you Tom,
not sure how to get my BT to forget Wyze. when I open my BT, WYZE is not there but it pops up as available withing a couple seconds. It only appears as an available device.

Something Odd just happened…There was also a BT device in the available devices named “WHSCL1”. I accidentally selected it to pair and it did…once it paired, I went to the app to install the band again and it paired and is now working. I had never seen WHSCL1 before and didnt know what it was. When WHSCL1 paired, WYZE still showed as available on the BT screen. Once I closed the BT screen and re opened it, WHSCL1 is still paired but WYZE is no longer listed as available

Now I am really confused LOL

WHSCL1 is the Wyze Scale. Do you have a scale? And was it paired before?
I have both and have never had an overlap problem like that! They have operated together without problem. I’m going to tag my fellow @Mavens and see if any of them can shed some light.
I have had problems with the band connecting & reconnecting, but the latest upgrade seemed to help that and the tip above has worked. Hopefully another maven can help.

Hi there. Sorry about the issue. Could you help submit another log and let me know the log number? I will work with our development team and check on it directly. Thank you and sorry about the delay in support.