Wyze Band, disable Alexa long tap action

not allowing it to be disable is a bad design. Anyone who folds their arms ,crosses their arms, has a child in their arms. Its a pain and should have been addressed.Also, it makes no sense as you have to talk to alexa, why add a touch button to activate it, when you can just activate it through voice. You are clearly in the minority of users here that activate it accidentally.

I don’t use Alexa, so a “long press” (which happens anytime I rest my arm on myself, like reclining & watching TV) can easily make the band think that I want to activate Alexa. I feel it vibrate, then hit the “back” button to cancel it over & over. I’m sure this drains battery faster than if it was not doing so.

EDIT: Can those of us who are loyal Wyze supporters be referred to as “WyzeGuyz” going forward ? (My 2nd choice is probably NSFW.

1 Like

I suspect a future update will bring a way to disable Alexa entirely. Although to be honest i noticed in the latest Beta firmware the screen lock seems to work more reliably which really helps guard against unintended screen presses.

To address your point about not needing to push a activation button for alexa,

You say just use your voice.,
I say HEC NO ON LIVE VOICE listening all the time.

I want it to work WHEN I want it to work and only then–again my opinion.
That is why we have no devices like, Home, Alexa, Dot , etc. sitting in our home.

I suggest this is the reason they designed it to need a request for alexa to activate—PRIVACY

I asked the question about this because as a tech , we ask questions when customers say “it dont work”.
Many times by asking more questions a way or alternate way can be found to fix the “i dont work” issue.
IE: the screen lock feature should be able to solve this question , maybe it can be adjusted to work better now they see the need etc. Maybe they will offer a way to disable in update. But again knowing what the users experience and WHY helps them help us.

The more Wyze knows about WHY and what circumstances folks are asking or complaining about lets them address the issue better and faster.
If on user has no issues and another does then COMPARE what is different and what is the same and adjust… I dont have the issue you do, WHY? what did I do so I do not…should that not be of interest…

When did asking questions because equal to attacking folks…or being upset etc…

1 Like

I agree , very easy update to disable I am sure.

I also agree screen lock seems to work,
I also noticed on recent update that the cameras respond much quicker etc…

1 Like

I’m CONSTANTLY being bugged to connect to Alexa when I rest my hand on the face of the band.

I don’t have Alexa, I’m not getting Alexa, this is a feature I don’t use.

It also triggered the prompt to establish the connection on my phone and I don’t want that either.


Your band watch connects with the Wyze app on your phone and that’s required for a number of the functions and keeping track of your fit data.
It will function as a watch fine without that connection, but you give up a lot of the built in features.

The band connecting with the Wyze app is fine, long press for Alexa, not so much!

I don’t want the band to do ANYTHING if I lean on it too long. I don’t want the error message, I don’t want to have to back out of that screen on the band, and I certainly do not want it launch an app on my phone that I have to dismiss… Every… Darn… Time…

I can see having this stuff pop up once, but I expect to be able to have the option to “dismiss forever”. It’s a blemish on an otherwise fine product.

The other features are just fine.

What I do need that’s not there is Google Fit integration. THAT would be useful.


I think this is causing my band to disconnect from my phone - or something is.

I set up some shortcuts to turn a Wyze bulb on / off, which work great until I try to click Shortcuts and it tells me “Disconnected from phone”, which is really annoying.

Mine comes on sometimes when I’m giving my daughter a bath. The water will activate the screen and push the button.

1 Like

I’d also like this turned off. For one I don’t use the Alexa as my home is currently a google play place. And secondly, every time that I lean on my arms on the couch it vibrates from long hold on some skin. Crossing my arms. Hands under head. Etc etc


I would like WYZE to offer a solution. I may have to stop wearing the band until Alexa can be disabled. If I come in contact with the band surface while sleeping it vibrates and wakes me up. I can’t even cross my arms during the day. I use Google and not Alexa anyway. Hopefully full Google integration comes soon.

1 Like

I also would like Wyze to offer a “disable” function. The Alexa function is great, but long pressing the button to activate is a little too convenient. It activates every time I cross my arm during reading blogs or watching movies at the desk. It would be very helpful if making it less convenient to activate, such as be able to activate it after the screen is unlocked. Right now we can activate Alexa anytime by long pressing the button, including when the screen is locked or the screen is blank.

1 Like

My band actually won’t activate Alexa on a long press if the screen is locked. I just tried a few times right now. I don’t know if that’s something that was changed in a software update or not but make sure you’re running the latest version of software.

I just tested mine again. With the screen locked, if I touch it, it wants to setup Alexa. I am running firmware It says the firmware is up to date. What firmware are you running?

So, how do you “lock the screen”? And unlock, of course.

I’m running I am using the Wyze Beta app so I don’t know if that would give me access to that version before the regular Wyze app or not?

I’m running now, and have slide to unlock enabled, and that doesn’t seem to do a thing. With the screen blank, I can wake it up by sliding down, as well as long pressing to bring up the Alexa pair thing - so i don’t know if you have to do something special to “lock” the screen or what.

Just wait a second or two and it will lock the screen. Sliding down will unlock the screen. I’m not running the beta version of the app as it isn’t stable in my experience.

Ok, then mine are “locking” but it doesn’t mean much - touch the screen in any way and it pretty much wakes up, even with lock enabled. Swipe up, down, left right, lean on the stupid alexa button - doesn’t matter, the thing wakes right up.

1 Like