Wyze app on Android emulator

Per advice from @K6CCC (are you a ham?), I added my cameras into a group so I could monitor them all at once, limited to two at a time on my iPad without having to scroll.

That got me to wondering if I could install an Android emulator on my PC or Macbook and run the Wyze app from there. Any of you have any luck in doing that? Which emulator and host platform (Win or Mac) did you use?

Yes, I am a ham. Sounds like an iPad issue. It should display three in portrait or four in landscape.

1 Like

Lots of folks have used Bluestacks, with decent results if I remember correctly.

If you search bluestacks on here you should see a lot of good info.

1 Like

Thanks, Jim. Yes I can see up to 4 on landscape but only 2 on portrait without scrolling. Hoping to get some mileage out of an Android emulator on Windows or Mac which might give me more flexibility. Thanks @R.Good, I’ll give Bluestacks a try.

Catch me on 14.300 MHz Intercon / MMSN most days

I’m trying Android-x86 under VirtualBox:

I have Android running but so far I can’t get the Wyze app to run; it starts up and then terminates. But I’m working on it… will report back if any success. They recommend 2 GB RAM for the VM which seems a little light, so I upped it to 4 GB and we’ll see if that works…

So far not working well… Wyze app crashes on startup and now the whole Android virtual machine is crashing… fortunately it’s all on a virtual machine and so no damage to the rest of my Windows installation.

Hey epnh

Wyze app is stable and performs well on BlueStacks 5 / Windows 10 in my experience.

A couple observations:

  1. It will not display cam groups 4-up in landscape – only in the single, scroll-able vertical column no matter what you do.

  2. To access SD Card Playback (or cam Settings) from a selected camera you have to do a little dance:

  • Select camera: Camera auto-displays full screen landscape
  • Select Rotate* from the BlueStacks Side toolbar menu
  • Select Back (left arrow) from the Bluestacks Sidebar menu: Returns to Wyze Home (or cam group) screen
  • Select camera: Camera displays 1/4 screen at top with View Playback bar at bottom
    Alternatively, you can enter SD Playback via a selected Event screen. (There is no alternate path to cam Settings, etc.)
     * Don’t select Portrait or Landscape via the BlueStacks Side toolbar menu - only Rotate. They don’t do anything useful and you lose the predictable behavior described above (requiring a Wyze app reinstall to get it back.)

Also consider installing Android app tinyCam. It’s a great multi-cam viewer (many layouts) and has a usable free - and a $4 pay - version. Plays well with Wyze. :slight_smile:

Anybody know if BlueStacks will run on a Windows 10 VirtualBox virtual machine?

If BlueStacks uses virtualization then the answer is probably “no” since to my knowledge you can’t run a virtual machine on another virtual machine, at least that’s what I’m told (never tried it myself although I use VirtualBox VMs all the time).

This piece is in the neighborhood of your question. Posted for general reference. :slight_smile:

I installed the Wyze app with the Windows 11 ‘Windows subsystem for Android’. Works for V3 cams but not OG.

Update regarding:

4-up in landscape can now be accessed reliably (at least) under:

Windows 10 / Bluestacks emulating Android 11 & phone Samsung Galaxy S22 Ultra

Wyze app 2.48.1(381)
Portrait Mode
8 Cam group of v2s, firmware

  1. Access group
  2. Select 1 cam
  3. Select Fullscreen icon   [ ]
  4. Select Back icon  <

Hi!! I have been using Bluestacks to watch my Wyze cameras with not problems so far. Now I that added a V4 camera the app crashes whenever I try to visualize it, I have assigned 4GB of RAM to video on Bluestacks and I am in performance mode. I am running Windows 11 Home and my PC has a Ryzen 7 5700G with 16GB of RAM. Does anyone know what would be causing this problem? Thank you.

Hi nmcar!

No v4, only v2s & v3s here, but…

I have a dedicated graphics card on a laptop with similar specs as yours…

Emulating Samsung Galaxy S22 Ultra and Android 11…

with this setting in Bluestacks toggled ON:

And within Wyze app 2.50.7 (487)   Account > App Settings:

1 Like

Thank you for your reply!

I tried with that configuration but unfortunately it keeps crashing.

I saw a post at reddit about this issue:


Could it be a codec issue? Can any Wyze rep answer?

Thank you.

1 Like

Nice link, thanks!

Unfortunately, Wyze doesn’t support third party software like BlueStacks. And the forum is primarily user-to-user assistance. Sometimes Wyze staff will chime in but only with Wyze product issues.

Your best bet may be to search for posts and/or create your own topic here:


BlueStacks staff seems responsive. :slight_smile:


1 Like