Wyze app crashes repeatedly when viewing camera in landscape

Pixel 3xl with newest wyze beta app update. Uninstalled and installed fresh, still auto crash the moment I turn to landscape whether viewing a single cam or a group.


Crashing when turning to landscape mode has been an issue with me since the beginning, regardless of camera version, or, phone.

I routinely think twice before going full-screen cuz sometimes it crashes, and, sometimes it does not.

1 Like

Clarification: My app never crashes. The connection to my camera sometimes “disconnects”, but only when switching to landscape while viewing 1 camera… never when viewing cameras in a group.

1 Like

What other apps do you rotate into landscape while using? Have you tried YouTube or any apps that involve video?

Unsure as to what you’re thinking subject line should be changed to…

All other apps that allow for landscape have zero issues. YouTube, photos, dji fly, reddit… Just the Wyze app when viewing a single cam or group

1 Like

I confused the posts right after yours with your situation. I will update my comments

Same phone, same issue here. Wyze is the only app that has problems with landscape for me. When I try to view a camera in landscape it just DC’s and returns to the camera list. App version is 2.16.23.


I’m on 2.16.24 (beta)… So some minor change I guess on my version, both of course having same issue. Hopefully they can address it. I sent in support request…

Having the same problems on multiple devices, ie. Ipad, Ipad Mini, Fire Tablet.
Have deleted and reinstalled on all devices to no avail. When turning devices to landscape mode app Wyze app crashes. Only started doing this after lastest update

Welcome to the Forum Community, @Jeff_CA.
I’m running 2.16.31 beta (Iphone), 2.16.25 (Ipad) on IOS and 2.16.23 on Android and none of them have this issue.
What Firmware are your cams using? on original cams, on v3s.

Have a one off v1 in mom’s garage, it crashes app when put into landscape, then the group has v1s and v3s, same crash.

Wife’s app on same exact pixel 3xl with same Android update has zero issues, and the difference is she’s running older version of app. That to me confirms it’s the most recent app update that broke it…

I thought it might be a problem with grouping the V2’s and the V3’s. I have such a group and just tried it and it rotates to landscape without any problem. I am on android 2.16.23 also. IOS on phone and Ipad are fine also.
I also tested with screen rotation on and off in the android settings. No problems there.
I’m going to tag in the other @Mods and @Mavens. Maybe someone else has a suggestion before we go to Wyze Support.

1 Like

I tested my V3 and V2 cams in group of 4 no problems rotating to landscape on iPad or Android. I’m using the Android Beta app v2.16.24 on my LG phone. I’m not seeing this issue on my end. Maybe one on the Mavens can test their devices on the production app.

I can’t reproduce this using the production iOS and Android apps. Tested groups of 4, 5 and 8 with mixed groups of v2s, v3s and WCOs (I don’t have any v1 cams). iOS 9 - 13 and Android 6 - 10. Also tested on an iPad Pro 12.9.

1 Like

Definitely app. Tried to access the spin camera (or whatever called) separate of group, crashes landscape. Single grouped cams crash it. Grouped cams crash it.

Final thing that makes me confident it’s app update, watching notifications will crash if landscape. Again, wife’s exact phone on same Android os update has zero issues with using landscape.

1 Like

I wouldn’t be surprised to find out this is device-specific and needs to be raised with support. I use a Fire tablet, and I see lots of issues. Of course my platform isn’t supported, so I can’t complain. Theirs should be. and I doubt anyone has a workaround. So I think all who are experiencing it should report it to support via the app, with logs attached just after the incident if possible.


I’ve submitted logs a few times, never contacted so came here. Another in this chain is reporting same issues with iOS devices…

Check your Testflight. The current update is 2.16.31

Thank you, keeping an eye out for it to hit play store. Not there yet. Maybe get lucky and it will fix

I have a pixel 4xl. I had the same issue. I was able to avoid it by changing my “system navigation” to “gesture navigation.” Unfortunately the app seems to disagree with “3-button navigation” on android. Really hope they can fix this issue as I much prefer the 3 button navigation. Hope this helps! Cheers