Wyze App 2.24 Beta Test; Wyze Robot Vacuum Firmware Beta Test 8/18/2021

This worked for me. I had to remove from the charger turn off then Back on… Mine never stopped binking white then after an hour I tried these steps and when it powered back on it said update successful.

1 Like

@QiS @Yichen @WyzeHongfei

Great job on the update. Some constructive requests:

  • Sunrise / Sunset in Rules, Love this option and turning it on now. However, I would like to only have to set the location once. I set my Home location in the Account Area, but for some reason on Every Rule, I have to specify my Location when setting this. Will test the Sunset and sunrise Rules tonight.

Will check out the spot cleaning next, but everything seems to be working so far.


Spot cleaning worked very well. Seems like the bot stopped to think a bit longer than usual, but finally being able to clean just under my son’s high chair is amazing!


Just tested some things on HMS and right now all my sensors show tune settings as off and I can’t change them. My iPad has the prod app and shows two as on, which is what it should be.

@WyzeHongfei @WyzeBaohua

Tested the spot cleaning, Impressed with the option and will use it frequently.

However, in the beginning it did take a little to think about what it needed to do, but it went to the area to spot clean. Below is an image of where I said to clean, I circled the island in my kitchen to clean around it but it kept trying to go through the island. I added an Arrow where the Vacuum went to and could not get by it. Question, is circling an item like I did, not allowed?

In addition, I cancelled the clean and it got confused where to go back to. I started heading away from the Charger, got passed where I told it to clean and then stopped, turned around and started to head back to the charger. On the way, it went back to where the Yellow arrow was, turned a couple of times, then went back to the charger.

I submitted a log if this will help: 277178

1 Like

Are you using iOS beta 2.24.21 exclusively? I’m not seeing this problem under Android beta 2.24.12 (don’t see 2.24.13 yet).

1 Like

I just checked my settings, On iOS they all do show as off when they are actually on. However, I can switch it to on or off without issue.

On my Android Device, everything shows on as it should be. I turned one off and went to the iPhone and it showed off. On the iPhone I turned it back on and then check on the Android device and it shows on.

I think this is a display issue with iOS. @Yichen , something to look at. iOS devices seem to not show the correct Tune Setting in HMS. Android Does.


I can reproduce this with my iPhone using the latest Beta as well. Looks like iOS is not reporting or displaying the setting correctly. The only difference is that I can change the settings on my iOS device.

My Android device, also at the latest Beta, shows it all correctly and can change it there as well.

1 Like

Log id: 277201

Yes, iOS only on an iPad and iPhone. The iPhone has the new beta and when I change the settings to on and then go back to check they revert to off. I have the current prod app on the iPad which correctly reports the state for the sensors.

Running v2.24.21 on the iPhone and v2.23.23 on the iPad. Submitted a log: 277168.


Thank you so much for reporting this issue. Could you submit an App log and post here? Thanks!

1 Like

Edited my last post with the log number, probably while you were responding. Log 277168.


1 Like

Thank you.

If there are any issues about sunrise/sunset, please let me know.

“If you’ve set your home location, you don’t need to set the location for each rule.” This feature is in our road map.


I’m excited to try out the vacuum updates, thanks for that!

Question: I updated the app and saw the sunrise/sunset rule options. I didn’t have time to set anything up, so when I went back to the setting, I don’t see the option to enable this. Anyone else not have these rule options?

I’m on 2.24.12 on Android

Ok, weird, the sunrise/sunset options are there again!

1 Like

That’s good to know, thanks for the info. I have my home location set, but had to provide the location on every rule I used it on. Can’t wait for the update for this.

You need to select a Time Option then set your start and end time to Sunset and SunRise. It will be displayed when you try to set it. Here are a couple of images:

1 Like

That is what I was trying, but it was not displaying for some reason. It is now working again - strange. :smiley:

Thanks for the help!

1 Like

Just ran spot cleaning twice… NICE! :+1: Did a normal spot in one room, then selected an area that crossed a no-go zone to see if it would adhere to no-go… it did well. Going to use this feature often. :smiley:

1 Like

Just tested as I am in Virginia. Interestingly Alexa says Sunset is 8:02pm, the Web says 7:58pm. Motion occurred at 7:57pm (but I am sure that there were some seconds in there) and the lights came on. So, I would say this is a success.

Great job… Will now see if the Sunrise End time kicks in tomorrow which is 6:29am via the Web and 6:31am via Alexa. Will post an update to this entry tomorrow.

Just checked to make sure things ended at Sunrise, and it did. Liking the Sunset to Sunrise option in the rules.

Can’t say this enough. Needed this feature for sometime. Great job.

Now we need multiple triggers in one rule to kick off the action and to all the ability to sequence actions. Turn something on, wait for this long, Turn something off.

@WyzeBaohua @WyzeHongfei @Yichen

based on the following:

Is it recommended to do a remap with the latest App and FW? I have a cleaning scheduled for Saturday, so if needed, I would like to do it sooner than later if needed.


One other observation: is there a reason I cannot place the spot box in the middle of a room where there is no walls, furniture, etc. Basically, I wanted to see if I can spot clean the middle of a room in the event the grand-kids spill something. When I place the box in an open area, it does not allow it and provides the message “No available area for spot cleaning”. See image below: