Wyze Air Purifier Firmware Beta Test 3/25/2024

Version: 1.0.18.0

What’s New:

  • Fixed an AQI reporting issue

  • Fixed an issue that caused a binding failure

5 Likes

Updating now via main Firmware update page

EDIT

Installed on both without issue, testing begins

Question

I have mine set to auto and the AQI goes from 1 to 3. Why am I seeing the message circled in red? Was not there until after the update

Same as @cyberdog_17

App Version: Android 2.50.0 (423)
AP Firmware: 1.0.18.0
Plugin Version: 2.43.0.6
Log: 1358259

Note: Just installed 2.50.0.437, problem still exists

1 Like

Still seeing incorrect AQI classification in the Air Purifier’s page. AQI is 4 and says it is moderate and will return to normal within 40 minutes all the time. It has been like this since device release. This needs fixed.


iPhone 12 Pro Max
iOS 17.4
App: 2.50.0 (14)

App Log: 1358221
Purifier Log: 1358215

2 Likes

Anyone else having issues with Air Purifier? Mine has always read in the 0 to 20 or 30 range with the occasional higher if someone burns toast in the house, but for the past few days it has been stuck saying it is Moderate in my house at 104 AQI and nothing I do changes it. I have ran it on Turbo, Auto, etc. and no changes in the 104 AQI at all!!! No wildfires here, no housefires, and we are running the apartment formaldehyde filer replaced Feb 2024. HELP!!!

1 Like

Has anyone noticed that the air purifier constantly now loses wifi connections. I have 2 running the beta firmware. Since then I have reset them multiple times. They work for a day and then go offline. They never had this issue before the beta firmware. This is the only issue I’ve noticed.

I am not experiencing this issue. I would unplug the power, wait for a few seconds, then plug it back in. Sometimes, this will reset the device and potentially allow it to be stable

Thanks. I’ll give it a try.

I have tried everything. Both units are a mess now. They constantly disconnect from wifi when they were perfect before. They work but, they won’t stay connected at all. I’ve unplugged them for a day, I’ve reset them multiple times, I deleted the app and reinstalled. They connect after I reset them but go offline in a day. I love the device and wish I never downloaded the firmware. I now have a new unit that I purchased for another room and I have removed the air purifier beta from the checklist so my new one isn’t a complete disaster. Is there any way to go back on the firmware? I never had an issue like this with any of my Wyze products of which I own many and most are on beta firmware.

Is there any way to go back on the firmware? I just received my new one and I didn’t update the firmware to see if it’s fine.
I’m guessing the latest firmware was not a beta? Let me know. I can then return the 2 I updated and have been having horrible time with…

Since I updated my air purifier to the beta version it has dropped offline twice requiring a hard reboot to reconnect. It was rock solid before the update

1 Like

Well, now the new one that worked fine before it updated is having the exact same issues with the latest firmware. I now have 3 units that are no longer working correctly thanks to the new firmware I have not received any communication but to unplug it. I did this for days and they all drop wifi in a day or two. I guess I’m going to have to call in to get these replaced under warranty. Thanks for all the help.

Same issue on 1 or 3 units I own. Crap wyze support says unplug and plug back in should fix. Nope.