Wyze 500 Internal Server Error

Am not able to view my subscribed services. Wyze web site throws a 500 Internal Server Error when clicking on the Services link under My Account page. This has been happening for several days already. (Feb 19, 2022)

Hey! I am having the same issue, how did you solve yours??


Please try
. Thanks!

Hi Desmond, yes I did as I told the wyze support agent (Ticket 2128491), I can access that page, but when I press “subscribe” it goes back to the error page

have tried several PCs, android, ios & safari, chrome , edge & VPN. Also tried several accounts

Nothing seems to give me access, support said tough luck try again later??? Been trying for over 24 hours

I see. When I press the “subscribe” page it goes to
directly with no problem. Any luck with cellphone app?

Still the same, as for the app, it says I can’t manage web licences in the app

May i know which service you try to subscribe? Camplus lite?

I am trying to disable auto renew on my existing camplus subscription

still having this issue 3 days on, idk what to do

I am just done with this seriously, a week later and nothing, no one has been able to help or answer if its just me or a common issue. From the forum, I can see many people have faced this issue over the years but solutions??

I was thinking of maybe upgrading to the unlimited cam plus, but now I just want all my existing plans to be canceled when they expire.

Can you do this ATLEAST, I can’t even access my current subscriptions! just cancel everything, seriously just done with this…

Why no response?? hello?

Even told my friend to try from a different country and still the same error!

Hi syedNO7,

May I have your timezone and username for wyze account? Thanks!

I have messaged you the information

Thanks! We are checking that now.

1 Like

Could you perhaps help me with this issue as well? It seems you were able to help syedN07.

Hello @ptrckcgreene, are you still experiencing this issue?

YES! I have been going back and forth with a email customer support agent by the name of Amanda and now another person just took over by the name of Richard. It just seems that everybody that chats with me from your company keeps suggesting that it’s an issue with my phone, computer, or internet and it’s in no way related to your internet servers. I’ve sent so many screenshots proving that it’s happening on multiple devices on multiple internet connections and also cellular networks.

Can you try this address and tell me if it works for you.


Please help them out, I faced the same issue until Desmond took my case and got it fixed somehow, maybe ask Desmond what was done to fix it.