NO HELP from support, Anyone else cant access their wyze web subscriptions? (‘500 Internal Server Error’)

Wyze support is absolutely useless for my case, they aren’t even responding to me anymore.

Keep Getting ‘500 Internal Server Error’ when trying to visit Wyze Home Monitoring Service to edit subscriptions

Wyze live chat basically told me tough luck they cant do anything, wyyze support on forum just keep saying they “have informed the internal team to check” its been over two weeks I was thinking of maybe upgrading to the unlimited cam plus, but now I just want all my existing plans to be canceled when they expire next week!

I cant believe this, Even told my friend to try from a different country and still the same error!

When you say Wyze Web Subscriptions, are you saying your account from a browser or from your app?

Sorry just realized the link you provided is the services link. I checked with my account and it loads fine. What Browser are you using? Have you tried clearing your Cache?

I use a Chromebook with Google as the Browser

1 Like

tried everything, different browsers, devices, OS, countries, VPN, incog, etc…

I have seen from the forum that several people have faced this issue over the years, but no update on if it was resolved.

The live support said cant do anything try again, other times they said they have contacted their cloud team because they recentley changed settings, but no reply.

Also, one agent asked whats my timezone, I told them, its outside the USA (though I manually changed my time and made no difference). Even then no response after that, so frustrating! I have an auto renewal on next week and I need to cancel and I cant access it…

Sorry to hear that,

Do you have any add blockers or some type of security around websites?

Try on your phone and put it on Cell Service and see.

1 Like

Already tried, no difference. Even diffent wyze accounts.

@carverofchoice @R.Good

Do either of you have any additional suggestions on this?

Maybe a country or ISP level block or transparent proxy. Although the corroboration from the remote friend doesn’t add up.

You could try accessing it by IP address I suppose. What server is returning the 500 error? Could you post a screenshot?

I am having the same issue. Tried different browsers, clearing all internet data, incognito mode. Continuously getting the error trying to click on “manage wyze services”

Lol they just fixed it for me a few days ago.

Desmond from wyze was the one I talked to, didn’t say why it happmed just said should be fixed now after weeks of pestering.

Their customer service is the worst. The chat agent I chatted with told me clear my internet cache at least 6 times then said to wait several days to see if the issue resolves itself. Then I emailed support stating I cleared all my internet settings, tried multiple browsers, incognito mode, cell phone on wifi and on cellular network, different computer. They replied to the email telling me to do EVERYTHING that I told them I already did. Then they told me to make a bug log in the wyze app and send them the bug ID to which I stated “how does this have anything to do with your website not working?” I gave the email rep the bug ID and she stated to just watch out for app updates and closed my ticket. THE APP ISNT THE PROBLEM, THE WEBSITE IS THE DAMN PROBLEM!!! I don’t get it!!!

1 Like

Can you provide the ticket numbers in these conversations please.

Can you try to access it via services.wyze.com.

If this doesn’t work, try logging out from the main website and accessing this again.

There isn’t a specific ticket number, but I was directly messaging @WyzeDesmond

Sorry, I was replying to @ptrckcgreene

I can’t access it from any version of the site. I’ve tried everything. It’s not on my side. It’s some issue with my account on their internal server. I’m being told their 1-800 has a simple fix for this issue but I called and just spent 57 minutes and 28 seconds on the phone, majority of that time I was on hold. Issue still persists and they want me to send yet another bug report from the app that has nothing to do with the website.

DM @WyzeDesmond he is the one who talked to the backend team and got it fixed for Me

I tagged him in another one of your posts and that person told me to contact the 800 number because they have a easy fix and direct access into my account. I guess wyzedesmond doesn’t have the access to fix it directly. But neither did the people on the phone. They claimed it was the first time this has happened.

It’s probably uncommon, but absolutely not the ‘first time’ many posts on this forum but no solution or explanation.

I would just message him again and say the call did t work out and ask him to look into it and forward your case to the relavant department personally

@WyzeDesmond I found forum posts that you may know how to fix the 500 Internal server error problem I’m having and have seen others have in the forums?