Wiring Error Msg - no yellow or white wire

I have a two zone heat/ac system with and oil fired furnace. I am attempting to install the Wyze thermostat and I’m getting a “missing wire” for both white and yellow when the app/thermostat do the test. I initially tried this on my downstairs zone and got this message. I wasn’t sure what the issue was so thought I’d try it on the upstairs zone. Exactly the same message. After reading through some of the other posts I put a meter on the wires. I get 24V between red and blue(common) however I get nothing between red and yellow or red and white. Below is a picture of the wiring at the air handler. I don’t have a control board on my air handler just this bunch of wires shown in the picture below. The wires in the picture below are has follows:

On the far left there is black wire with two leads connected with blue wire nuts to a red wire and the light blue wire. This from a separate 24V transformer which I am using because there was no common wire used on previous setup. I had the extra wire - blue - from the the thermostat. I was just easier to use this than mess around trying to get to the common inside the furnace.
The lone red wire capped with a yellow wire nut is the old power wire from the transformer inside the furnace. Thermostat is getting power from the new transformer.
In the middle is the green wire attached to the air handler green wire with a blue wire nut. On the far right are two yellow wires attached to two somewhat thicker red wires with a blue and an orange wire nut. Those red wires go to a float switch in a pan that sits under the air handler. Since the unit is on the second floor this is a safety in case the pan doesn’t drain properly. Normally those two yellow wires would just be connected together.
Finally, the white wire from the thermostat is connected to another white wire coming out of the furnace and the are connected to a tab on the brown block above. I’m not sure if that is a contactor or a relay. The two red and white wires at the top of the contactor/relay go down to the furnace (I’m pretty sure about that)

Long message, apologies. Just wondering if anyone has any thoughts given this wiring setup why the error msg from Wyze. When I re-connect everything to my old programmable thermostat everything works fine. Is using the separate transformer possibly causing an issue and I’m not getting a proper power loop through the yellow and white wires?!

If you added a separate transformer to power the wyze, you cannot use the cooling features of the wyze, because that transformer is not connected to your cooling system. It would be much easier to just get the common from your existing system and not deal with 2 different transformers.
The way a thermostat works is by switching hot through a load which is connected to common on the other end. If you have 2 separate transformers, that hot and common are not connected to each other and so there is no way for the current to flow through the load. The only load your wyze can control the way it is currently wired is itself.


Once again thanks for all the advice. I should have heeded your recommendation a few days ago to tie my extra wire into the air handler common. I wasn’t confident about that and decided to buy the separate transformer as that popped up on several sites as a solution for people who didn’t have a common wire in their system.

Anyway, based on your feedback I tried one of the terminals on the side of my air handler that looked to be a likely candidate for the common and Voila! The thermostat powered up and no error messages during the self check. It is operating fine now. Many thanks for the assistance.

1 Like