Why does Wyze keep saying 32GB is max limit for microSD cards?

Yes, I have seen https://support.wyzecam.com/hc/en-us/articles/360012429891-What-size-and-kind-of-microSD-cards-does-Wyze-Cam-Pan-support-# that talks about the size, but, unless Wyze is doing something odd with the firmware (that source changes don’t show), then there should be no reason at all to limit the microSD card to 32GB.

Let me elaborate, FAT32 does have a limit of 2TB for partition size, and it also does have a limit of 4GB for file size, but, that is the only limits it has.

Wyzecams don’t write files that big, and, nobody is using a >2TB microSD card.

*Note: The camera will recognize larger cards (64GB+) that use exFAT, but these cards are less stable and are more likely to experience issues in the long run.

exFAT is an all around better, faster, and more robust filesystem, so, in what way would these be " less stable and are more likely to experience issues in the long run"?

You can format ANY of these cards to be FAT32, as I mentioned, the limit is 2TB per partition. If you don’t want to use exFAT, that is fine, but, there have already been millions of hours of testing of exFAT, and, it is more robust than FAT32 ever was.

Now, on to the size of the microSD card. In every single case, the bigger the NAND capacity is, the better it is for write leveling.
These cams write data, and the more times you write to the microSD card, then the less life it has left, which is why bigger cards are better, and provide more robustness in longevity over smaller cards.

Which finally brings us to this part of the article linked above…

While there are ways to force larger cards onto the FAT32 format, they are less likely to be recognized by the camera and may corrupt your data.

Why is that exactly? Linux kernel 3.10 doesn’t self impose a artificial size limit, and how exactly would the data become corrupted just because you used a bigger microSD card? I looked over the 3.10 kernel patches, and nothing in them would suggest that anything can be corrupted data wise because of the filesystem.

Please keep the replies of a technical nature, this is meant to find out exactly what is going on here with the verbiage in that article.


I am using a 64 gig SD formatted with Fat 32 in one of my Wyze Pan Cams, with the last 2 firmware updates since March 2019, max limit for SD cards might have changed and Wyze staff has not had a chance to update their support pages yet?


I was talking with SanDisk support last week and they do not recommend continuous recording mode with any SanDisk cards using any webcam (voids the SD card warranty), he says.
They did send me another 32 gig card replacement, as a “courtesy” for the SanDisk Ultra C10 card that has been used in a Wyze Cam version 2 cam exclusively for a year and a half now. I did only have the record “Event” triggered though, never using Continuous Recording, but somehow the format command through the App screwed the card up during this time period.


1 Like

I have to ask the same question. When they make 1TB MicroSD cards now, why are we still limited to 32GB? It doesn’t matter if they are recommended to continuous record or not.

Why are companies like WYZE still limiting the sizes of the SD cards we can put in (even if it is in verbiage only)? I don’t get it.


I’ll address part of the OP’s original post here:

exFAT is a fine improvement over FAT32, no argument there. However, exFAT is a proprietary Microsoft format that is not as widely supported or stable as FAT32 on non-Windows systems (especially a Linux-based firmware that may not have the option of the latest kernel/drivers). I have no inside knowledge of the Wyze firmware, but I know from past experience that embedded firmware can have all sorts of quirks and hardware interaction oddities that may be easier to work around than try to fix.

The official SDXC specifications list exFAT as the only supported filesystem. Formatting as FAT32, NTFS, or ext3 is certainly possible and in most cases will work fine, but the card technically no longer meets the SDXC specification and could cause problems in devices that expect SDXC- or SDHC-compliant cards.

I too use 64GB and 128GB cards in my Wyze cams without issue, but I can understand why Wyze wants to stay within the SDHC-compliant 32GB/FAT32 limits for official support.


Fat32 is limited to 32Gb,

That’s definitely false.

Edit: Are you talking about what’s officially supported in SDHC standards? If so, then yes, that’s true. But in general, FAT32 volumes are limited to a little over 2TB. an individual file on a FAT32 system is limited to a little over 4GB.

1 Like

What @ nerdland said. That’s just not true. FAT32 != 32 gb limit

I’m using a Sandisk 256 and have been for 4 or 5 months, with no issues… not sure either why the 32 limit is posted …when I format in fat32 it formats fine and displays 256g

1 Like

All of the SD cards i’m using are at least 64GB, and they’ve all been working for years without issue. I think Wyze’s limit is more of a CYA type of thing. I have a feeling the manufacturer published this to them, and they’re just passing it on, so if something does happen, they can say they only recommended 32.
And, technically, that follows the SDHC standards.

If you look on the support page it says this:

The camera will recognize larger cards (64GB+) that use exFAT, but these cards are less stable and are more likely to experience issues in the long run. While there are ways to force larger cards onto the FAT32 format, they are less likely to be recognized by the camera and may corrupt your data.

In order to be used in the camera, SD cards that are larger than 32G need to be formatted differently than they usually come. So you can’t just stick it in there and use it.

For most people, this means calling support, finding out how to do it, using your computer to reformat (sometimes getting software to do it), et.al.

It’s easier just to say, “we don’t officially support that.”

1 Like

@Wrecks0 In my case, that hasn’t been true.

You don’t actually need to format the card in any different way. And if you do, there’s no need for a computer or any new software. Most of my SD cards (all larger than 32) just worked without issue. However, there were some cheap ones (I’ve since replaced) where I opened the Wyze app, and hit Format in the app. Then after a couple seconds the camera will format the card, and you’re on your way.

Good, and accurate, point.

Nope - clearly not the reason. I just stick 128GB cards in, and they’ve worked fine. Never had to do a thing to them. Of course, if I want, I can format it in the camera - which also works fine.

1 Like

I formatted a 128gb with exfat on a win7 PC and it works fine. Same with a 64gb.

1 Like

Just to give my hands-on experience on this, I am using a 64gb SanDisk Class 10 on my Wyze Cam Pan and I’ve had no issues so far.

Technically the max volume size of FAT32 is 16TB with 4kb sectors, 8TB with 2kb sectors, and 2TB with 512b sectors. The max file size is 4GB - 1 byte.

The reason people think that FAT32 has a 32gb limit is because Windows will not format using it when the volume is over 32gb. Somewhere I read this is because the volume becomes unstable, but I had also read that it was just arbitrarily picked by a developer. From my experience of over a decade in the IT field, I can tell you that it isn’t unstable over 32gb. I have used many 128gb cards/USB drives in FAT32 (formatted by a third party program, not windows) and could fill it full and all data is fine. The issue with the WYZE cameras could be because the firmware cannot handle large sector sizes that come with larger volume sizes.

Wyze is one of the few companies that has managed to make very fine products that won’t break the bank and has also managed to gain respect and participation of a large community of users (from amateurs to tech pros) who often provide highly valuable help and support to each others and are more an asset to Wyze itself who AT TIMES listens to the requests of the community.

That premised,… Most discussions of using SD cards over 32GB could have been easily put aside (or at the very least minimized quite a bit) if Wyze had finally implemented a function what I’ve been requesting (under other usernames) since Wyze came out with the very first camera: Allow recording to a network resource (be it a network drive, a NAS appliance, a shared PC you name it) using SMB/WebDAV/SFTP or similar protocols to store a on local share either directly or by using the SD and copy SD content to the network share. Maybe in the near future? It’d be a long time since I requested, but it’d be a very welcome feature addition that many of us are still waiting to be implemented :slight_smile: