Who is responsible (to blame) for the "SD" coding, Xiaomi, or Wyze?

So today one of my V2 cams wouldn’t let me view any files on my SD card and claimed there was no SD card.
This camera has a new 32GB SD card that I installed about a week ago.
I tried to restart the camera, reinsert the SD card, etc., but it still failed to recognize the SD card.
I removed the SD card and put it in my PC. The card was fine and had recorded video up to the time I powered the V2 off. All of the videos were fine and not corrupted. I put the card back in the camera. Under "Advanced Settings > Local Storage> it still didn’t see the SD card.
I deleted the camera, downloaded the newest release file (, (March 18, 2020) yada, yada, yada and re-registered under “Add Device”. Now it is working fine and recognizes the SD card.
The point is: I have other brand name cameras installed and Wyze is the only one hiccuping with the SD cards. I think Wyze and some users have been too quick to blame the SD brand, size, etc. Search the forums of other manufacturers and you find SD card problems mentioned far less frequently.

It’s time for Wyze to re-examine the basic code structure as it relates to the SD card.
Who is responsible for the “SD” coding, Xiaomi, or Wyze?

(I apologize for starting a “new” “SD” thread)

1 Like

Interesting as I had the exact same scenario with a V2 this morning, after it had been chugging along perfectly for 6 months. Only difference is it went off line first for absolutely no apparent reason.

You’re describing my normal Wyze SD card experience. It just doesn’t work reliably enough to even bother pursuing. The cameras randomly decide they either can’t read the Wyze branded card or don’t acknowledge it’s there. It was that way from the week I received them, and I eventually gave up.

Just like the cameras themselves do, I now pretend the SD cards aren’t even there.

As to your question, of course Wyze is responsible. Whatever the OEM gave them, Wyze has reworked it dozens of times.

I think maybe other hardware factors may also be involved. Maybe a slightly different chip version, bad batch, etc. The camera I had the problem with was the V2 Black Cam.
What bothers me from reading the threads is Wyze doesn’t seem to attach any particular importance to putting out this fire.

One of my Wyze v2 cams had this problem and then several days later it started having connection issues (would somtimes go offline, took longer to connect then other cameras, even after re-initializing) this got progressively worse (more frequent and longer delays), then several more days later it couldn’t connect at all. So I returned it (still within the return period thankfully) and got another, now have 5 and all work ok, no SD card or connection issues. I use a few different brands of micro SD, Sandisk, samsung, not sure who else. This may be a sign of impending hardware failure.

Oh btw, it would sometimes see the microsd card, sometimes not, sometimes it would report less space then the actual (32Gb card, it would say 9Gb or 7Gb or 1GB TOTAL space, not free space). Formatting inside the Wyze app did not help. I also tried formatting under Windows, that seemed to help then the same problems slowly returned. Switched to different brand microsd, same issues. Eventually returned the camera, new replacement one working just fine.