When I record video it sometimes saves & sends it as a "Draft" to my e-mail. As a draft there is no video to download from my e-Mail

Pretty much says it all in the title… I go back to look over video that has been recorded by the cam.Events are only 12 seconds so I just use them to see when something started. Then I go to the Playback video with the time slider on it to find the time of some action I want a recorded record of (more than the 12 seconds). I hit the record button & can usually record up to a 5 minute section. Then when I hit the button to stop recording a few seconds pass & I usually see “saved” . It might say “saved to album” all is good. I go to the album & play the video & hit the share button & it allows me to type in my email address & sent that video clip to my computer to save there in my file system of video records. BUT sometimes it says…“Saved as a DRAFT” . I can still get to it in ALBUMS & Play it & share it to my e-mail BUT when I log into my e-mail it is in the (Draft)
envelope in my e-mail & there is nothing or no video to download?
What I really don’t get is why if I wait a few days or keep signing in & out of my e-mail it will suddenly jump into my INBOX as a VIDEO CLIP that I can now download? It seems like this is starting at the point when I save the video clip on the wyze (or do I mean to say the wyze app on my phone). But it’s just this random thing. One day I will sent 2 or 3 clips & they will ALL go correctly into my In box in G-Mail. Anothe time they will go to this DRAFTS folder (I guess because when I hit the stop recording button WYZE for some reason RANDOMLY saves the recording as a “DRAFT” .
Sorry for so long a post…Just want to describe in as much detail as possible.
Can anyone explain this to me or tell me how to fix it from doing this? Anyone else run into this as an issue? I just have one simple little wyze cam box camera with a free account (no paid subscription) so I only get the limited 12 second clips BUT with the SD Card in the camera it loop records a few days of video that I can go back and watch/record when I know what time an “event” took place.
Thanks in advance any help or reply’s.

The problem you describe seems to have nothing at all to do with Wyze.

The Wyze app did its job. It saved the clip to your phone. Your issue is what you try next, invoking your phone’s sharing feature and e-mail program. Longer clips are going to be larger attachments and may fail to properly transmit. If it were me I would just attach my phone to a PC and copy the video clip directly instead of trying to e-mail it. You could also upload it to something like Google Drive or Photos.


For reference, 12-second clip is typically 1-1.5 MB in size, so 5 minutes would likely be in the range 25-40 MB.

Most mail programs are typically limited to 25MB, and I see Gmail handles that this way: If your file is greater than 25 MB, then Gmail automatically adds a Google Drive link in the email instead of including it as an attachment.

I agree with @customer – try uploading it to something like Google Drive or a share service like SendAnywhere, where you can transfer multi-GB file sizes. :slight_smile:

Did you know that at the bottom of the event clip (on a V2 or V3 when you are in portrait mode) there is an SD card icon labeled Playback? This will take you DIRECTLY to the same time & date on the SD card, without using the time slider to find the time. :slight_smile:


Respectfully I must disagree. (I probably did not describe the issue with as detailed of information as needed).
This issue happens when I am on the WYZE app on my phone. I am watching/ recording video from the “playback mode” or “view”. (Because I AM AWARE of the MB limitations of clip size that can be sent to G-Mail) I usually try to limit the size (or length) of the recorded clip to between 2 to 3 minutes. When I hit the button to stop recording it says (after about 3 seconds) “SAVED SUCCESSFULLY” . All seem good so far… Now I can either record more clips OR just go over to the “ALBUMS” (because as you know that’s where the clips have been successfully saved to). Now I can choose one of the recorded clips.I hit the play arrow in the (box photo image of any particular clip). The video clip will begin to play & along the bottom are the icons for SHARE - SOUND - DELETE. I choose the SHARE icon which pops up the WYZE screen for the options of who I want to share this to. I choose the G-Mail Icon which pops another screen which (automatically) has MY WYZE account “FROM” field box filled in. BUT ALSO as soon as this screen (pops up) at the bottom of the screen the black boc with white text pops up with ONE OF TWO MESSAGES. Either "Message saved as DRAFT’’ (This is the problem pop up save issue) , OR it says "Message Saved’’ (In THAT case there is a small box underneath with what looks like a movie clip snap board & a file number as well as the file size in MB). EITHER way I can SEND the clips to my e-mail! BUT the clip that is saved as a “DRAFT” BY THE WYZE APP (Not G-Mail), Ends up in a “DRAFT BOX” in G-Mail without any means to download the video clip/file. This can & does happen with very short length/small size clips of 1 minute as well as longer 3 to 4 minute clips. IT’S COMPLETELY RANDOM (AS FAR AS I HAVE NOTICED). BUT these “DRAFTS” in the “DRAFT BOX” in G-Mail WILL again at a RANDOM TIME suddenly (jump into) my IN BOX where they ARE DOWNLOADABLE and have the clip attached as a file to do so. Sometimes it takes a few hours but usually a day or two. THAT’S what I just don’t understand. Well I guess I know as soon as I see "Saved as Draft ‘’ that they will end up in the Draft box in G-Mail. Just can’t figure out the RANDOM way some clips are saved initially in the WYZE app & the RANDOM jump from one box to the other in G-Mail???.

Anyway, That’s why I say I disagree. This does NOT seem related to G-Mails functionality or as far as I can tell anything to do with my phone or the size of the clips. It seems related to the WYZE APP I am using on my phone to do all this.

PS: Thank you NewsHound, I am aware of using the “EVENTS” 12 seconds clips to get to the section in the long timeline playback mode to find the area of time I want to record more than 12 seconds of.

PS: It’s not convenient to have to take the memory card in & out of the WYZE camera & insert into my computer. That’s why I just send them to G-Mail.
Understand, I have been able to get the clips. This is just a question about the random way they are saved as either just “Saved” OR “Saved as Draft” messages that pop up when I am “Sharing” them to myself (Sending to my own e-mail)
Also I have tried to send them to a different E-Mail and I get the same results.
I’m sure there is some reason for all this or an answer. I’m just not sure that (the file is to large & g-mail limits file size) or that there is any reason I need to use these 3rd party apps to send these clips. As mentioned, They DO eventually get through. It’s just not as expected & in such a random way.
If you have any other ideas to try please tell me. Thanks for the replies.

IN FACT…Even as I write this response, 11 of the 16 “DRAFTS” in my G-Mail have “JUMPED” into my regular In Box where I will be able to download them to my computer!!!
5 have remained in the DRAFTS box!!! Likely by tomorrow they also will (JUMP) into the Regular In Box!!!

I just tryed it on my android I went to playback on my V2,V3 and did a 45 seconds record and hit download and both were in my gallery,then I emailed each 1 and both worked with no issue,but if I hit the forward arrow it fails…o well no biggie as long as they both capture the events…

I guess the object here is to post if you figure it out as well. Re This issue of sending to my G-Mail as a draft…I have found the answer to be to send to Google Drive instead of my e-mail.
Was not failure with using this Google Drive thing. Not sure why I had the “Saved as Draft” thing happen when I sent clips to my regular e-mail. Especially was not sure why they would (sometimes) at a later time switch over to my In Box where I COULD download the video.
All I know is that sending clips to Google Drive seems to have solved the issue.

1 Like