Why no 12-second clips

I have three Wyze cameras. Every now and then I notice in the events mode that one of the cameras is not sending any clips. And there is plenty of sound and motion going on. When I restart the device it seems to fix that problem but not sure why it does it in the first place. Obviously I can’t have a camera that stops sending clips and sometimes it’s a while before I actually notice. Certainly can’t have that in a security camera.Wi-Fi is close by and when it happens to one camera, the other two cameras are working fine. Love these cameras but a bit baffled by this behavior. Playback mode seems unaffected. Thank you.


I also have this problem. I believe that this issue occurs when the camera has been using for several months, if not years. My solution is to create several schedules in the Wyze app to restart the camera at the certain times of day when I noticed it stopped uploading 12-second clips. You will know the time it stopped uploading when the first “unsuccessful” upload states the error message " This video doesn’t exist in the cloud or is still being uploaded". However, it seems to me so far that Complete Motion Capture doesn’t have this issue.

Wyze doesn’t claim these are “security” cam, so end users should think in the same mindset.

Double check the settings. …
a) Also, does the questionable cam show ANY “Event” clips?
b) or is it sporadic?

Okay not using for security. Using to see what’s going on when I’m not around. Once clips stop, they stop. My sister purchased a wyze cam and she had the same thing happen. As I mentioned I have 3 wyze cams and over the months they’ve all done the same thing at least once. No it’s not my WiFi. With three wyze cameras all doing the same thing at least once, makes me think I am the unluckiest guy in the world if I’m the only one with this problem (and my sister). A simple restore seems to solve the problem but a lot of notification clips are missed if not discovered in a timely manner. Again, Playback is still there. Thanks.


Mine is brand new and not recording a thing. I was in and out of the door for more than 12 seconds several times today and it didn’t pick up sound or motion. Worthless!

1 Like

[modified due to subject drift]

My issue is not rhofnash’s issue so not sure why an answer to his issue is winding up on my feed. But I’m sure he appreciates your response.

I’ve done all that. It hasn’t recorded a single clip since I got it. Not one.

1 Like

I just posted about the same problem–didn’t see this one posted. This has been going on for quite a while now (maybe at least 1 month) on most of my cameras. As you said, resetting the cameras starts up the event recording. Not sure if this has repeated on a single camera.

1 Like

You need to restore the firmware. I also had similar issue with one of my cameras. I contacted customer service and they recommended me to restore the firmware. The issue was solved. I think that the firmware was broken after it was trying to update the firmware.

Done that. Didn’t work

Hello. Thanks but not sure what you mean by restore the firmware. On each of my cameras it says the firmware is up to date.

Restore firmware to some previous version where XXX worked.

I have 4 wayze cams and have similar issues. One thing I did notice is two of my cameras I had to keep resetting to get them to send a recorded clip. Then realized I had installed 64GB SD cards in them. The cams should only have 32GB SD card size or less. After replacing them, the two cams started to send the clips regularly once I set the sensitivity up. I do have to reset the cams about every two months. Also, one thing I noticed too is that after the 12 sec clip, it will not record any other activity for another 10 min or so. Like I can see a delivery truck show up. So essentially not great for security purposes. Not sure if setting the sensitivity to activity to the highest will it record back to back activity while it’s happening.

I guess everyone’s Wyze system works differently. Our cams have 64gb Sandisk Extreme cards in them and work flawlessly.
(And we installed each card straight out of its packaging and into the cam … no out of cam, or in cam, formatting).

Restoring the firmware means manually download the firmware file from the Wyze site and copy it to the SD card. Basically it would reinstall the operating system in the camera. For more detailed steps, please see the following article:

Possibly. I had contacted tech support and they stated I shouldn’t be using SD cards larger than 32GB as that is what the stated support size was for the cams. I don’t have the rotating cams, just the standard ones.

I have a 2GB SD card in, it never made the beep but seems to recognize it.

I am not getting 45 sec clips, only 12 still. Also, what is the point of this if somebody can just take the camera AND the SD card?

They said 60 sec clips here on SD vs 15 sec.

I have a similar, though more bizarre problem. I have a Pan cam under the garage eave looking out over thirty feet of driveway right in front of the garage, a 75 foot diameter circle beyond that, and a couple of hundred feet of driveway beyond that. Twenty feet west of that camera is a regular Wyze cam looking out the window into the front entryway. I pay for continuous capture on all the cameras. The one over the garage infallibly records my wife or me whenever we go in or out the garage into the driveway and the other camera whenever we go into or past the entryway. And here’s the weird thing - NEVER has the garage cam recorded the delivery trucks coming into and stopping in the circle thirty feet from the camera, and NEVER has it recorded the drivers walking up the drive toward the entryway. We get deliveries from UPS, Amazon or Fedex once or more time a day. All of those drivers are recorded putting the packages in the entryway, and the Pan cam is always recording one or more palm trees swaying in the breeze within thirty feet or so. That Pan cam was put there to record a vehicle that has no business being there, but it seems unable to record any strangers or their vehicles!