What to do if new Wyze OG Telephoto will NOT update firmware?

I just bought a new Wyze OG Telephoto cam.
I have it setup.
But it says it needs the firmware updated.
So I clicked Update.
First, it said “Update failed.” Try again.
So I tried again and now is updating for the past 30 minutes.
How long does it take to update?
How long should I wait before I decide it is NOT updating.
What should I do if it doesn’t update???
Why does Wyze NOT provide a “Progress bar” like other vendors do?

What version is it?
Generally it is not critical to update. Wait till the next update comes out and try again.

1 Like

A lot of times these are completely fake. During the update process the camera is offline, and won’t be able to tell the app when it gets through different stages. The only thing the app could possibly know is if it’s in the downloading state or the updating state, which is very little useful information.

Apps and sites will put fake progress bars to make the user think everything is going well and they are in control, when usually this progress bar is an estimate and it jumps to the end when the cam actually checks back in.

I don’t see the OG Telephoto but his has info. for the OG??

Ive had this many times with my V3 and Outdoor V2s. The fix is generally 1 of 2 things:

  • There is an app update you need to install the firmware properly, get that first.
  • Power cycle the target camera, and start the update standing in front of it. This way you can watch the little status LED on the camera to monitor progress.

Don’t trust the app until you see the camera reboot at least once. One time, I had to power cycle it for a second reboot when it did not come back online after it rebooted itself.

It downloads the firmware direct to the camera, so that part is the most variable time. If your internet or WiFi is slow, or Wyze servers are busy, it can take a few minutes to download. Then another few minutes to update, then you will see the light go off then come on for a reboot. After another minute, I usually wave an arm to see if that triggers recording. When it does, its done. About 5 minutes total with fast downloads. 10+ when slow. And once the LED seemed stuck after reboot, so I power cycled the camera and it came up fine.

Thanks for your reply.
I have checked the Wyze App on both my iPhone and on my iMac.
Apple says there are no updates.
I have Wyze app version 2.41.0
Is this the latest version for the Wyze App?
Is this the correct version?

I tried everything you suggested and nothing worked.
I think I just got a bad camera.

As I said earlier, just wait till the next update. It is very seldom critical to update.

I just looked at one of my OG-Tele cameras and it’s firmware version 1.0.59 (I’m a beta tester, so that may well be a beta version).