WCO v2 & Solar Panel - charging trouble?

My experience is you probably have a Outdoor Camera hardware issue.

I share 2 solar panels between V1s and V2s.

One V1 has SO MUCH trouble staying charged. So much that I keep the solar panel connected to it full time. The V2 on the pair is cool; it can wait patiently for the next recharge.

On the other solar panel, both the V1 and V2 are cool.

So I suspect a failure of the V1s battery on the one side that isn’t acute enough to cause total failure yet.

You may want to pursue a warranty replacement on that one if you are still able.


I purchased it through Amazon and literally deployed it on June 9th. So you are saying it worked okay for 2 weeks and then hardware has gone bad on the wco v2 itself?

This installation is about 500 miles away from me, so I’ll have to be creative.

Opened ticket #2179035.

1 Like

Oddly, without intervention, I’m showing a 1% gain today with wco v2 still off via app.

Parents also just had a visitor at the house who was comfortable climbing a ladder. Had her remove the charging cable and flip the power switch off for 5sec and then back on… AFTER having observed the 1% gain above.

Confirmed that positioning was still good and then powered the cam back off via app. We’ll see if any further gain with remaining sunlight.


Sorry to report that disconnecting the panel & power cycling didn’t make any difference.

Charging indicator still shows during peak daylight hours but the camera battery does not regain any charge. The 1% uptick I reported above was apparently an aberration… :man_shrugging:t2:

I’ve submitted log bundle & opened support ticket thusly. Have submitted proof of purchase and the other information they requested. Hoping to get both a new cam and panel since it’s unclear which is at fault in this case.

Log Bundle - 628117
Support Ticket - 2179035


This bakes my noodle a little bit…

Received warranty replacements for both the cam & solar panel. Coached my mom through setting up the cam and pairing it with existing base. Today, someone inadvertently unplugged the solar panel from the existing cam for about 20min and then plugged it back in. Charge went from 76% to 91% as sunlight waned. This charging performance is precisely how the current equipment operated during its first two weeks of deployment. Not sure what has caused the laggy inconsistency recently.

Not sure how to make heads or tails of this, but definitely curious to see if I get back to 100% off the existing rig during peak daylight Friday. Neither cam nor solar panel have been replaced as yet, although replacements are ready in the bullpen.

EDIT-1: This previous behavior has resumed. Charging symbol is present, but cam battery continues to slowly drain… :man_shrugging:t2:


I am having the same issue. First hooked it to solar after 100% charge. It worked a couple days and stayed fully charged. After a week or so I say the battery drain 1% a day. Then called support and they sent a new panel. First I charged the cam to 100% again and it took about 12 hours which it should not. The for about a week it was fully charged. Then it started discharging the same way. Is it a bad camera or just a bug. It is so annoying as I wan to add more but not if this is the experience.


I have started having this issue as well. My v1 WCOs don’t do this, but my v2 does. It just slowly drains 20%, and then kinda stays there for a while, and very slowly goes down 1% every day. Never goes back up until I plug it in


Sadly, I am resigned to this outlook… :expressionless:


Next visit down to my folks’ place, I’m pretty much gonna dismantle the whole installation and scrap it at this point. Self-sustaining power was a requirement in deploying a battery operated cam there. No way I’m putting a manual charging onus on the parents - total deal-breaker. Got enough Bravo Sierra at my abusive job that I don’t need to babysit a camera that’s SUPPOSED TO BE watching MY back.

Disappointing that their marketing is out over their skiis and way ahead of product development yet again. Style over substance when the actual product doesn’t do what is advertised. Another stellar feat of Wyze QC… or lack thereof.

[Mod Edit - not family friendly]

I guess I’m here to add to the “me also” chorus. Had a v1 charging off of a panel just fine for months. Upgraded to a v2 and after an initial charge of a day, it just starts draining instead. I purchased a second panel for another v1 cam I hung up so I guess I’ll test the v2 on the second panel as soon as it arrives. But something tells me this shouldn’t be a panel problem when all I did is upgrade the cam. :expressionless:


For the sake of the community at large and the persistence of the issue itself, I’d suggest un-marking this topic as having a “solution”. :upside_down_face:

1 Like

Indeed… That post was written at a pinnacle of concurrent frustrations :smile:

1 Like

This is actually a really good before & after comparison. Wouldn’t it be nice if Wyze had done similar instead of QC always falling on the customer base?

My parents have received warranty replacements for both the panel and camera. The issue has been getting somebody on hand who is comfortable climbing a ladder to replace the cam. Nevermind the effort behind the custom protective hood that I put on the original cam.

Hey @WyzeJasonJ sorry for the second ping, but it seems like this is definetly a widespread issue now. Let us know if you need app logs, Mac addresses, device logs, etc


Here’s a set ready to go…

Log Bundle - 628117
Support Ticket - 2179035

1 Like

Sharing an update of my experience as an additional data point.

When I first installed my WCO v2 I didn’t fully charge it via USB. It had over 80% charge from the factory and I knew I was going to get charged from the solar anyway. I figured a few bright summer days and it would top off. After that, I was observing what I posted above.

After posting to this thread, my cam was down to 50% or so, so I decided to throw it on a battery bank charger (the one that came with the Wyze car :wink: ) and get it back up to 100%. While waiting for it to charge it seemed like the last mile from 99% to 100% was taking an observable amount of extra time. I’ve seen v1’s charge to 99% and then when I pull the charger off they say 100%. So I took the v2 off the charger and it was still 99%. I plugged it back in until it actually said 100%. At which point the Wyze app pops up the message saying your camera is charged, don’t forget to put the cover back on, something or other.

For the past three days, the cam has stayed charged at 100%. Yesterday was even a bit cloudy. Last night I saw it dropped to 99% and this morning back to 100%. So suddenly it’s working (charging) properly the way I had observed the panel charge my previous v1.

Once again this points in my mind to the cam and not the panel. I don’t believe it was a connection issue as I would observe the charging indicator come on during the day and go off at night and had unplugged and plugged in the solar charging cable 2-3 times. However, I’m almost afraid to touch (unplug) it again for fear the behavior will return. But once in a blue moon I have to reboot a cam that stops responding to the bridge and since the solar plug covers the switch, that will be unavoidable at some point. :pensive:

I don’t suspect this will help the OP and I’m not suggesting this is some kind of fix-all. But if your experiencing this behavior and you didn’t a) charge the camera to 100% prior to putting it on the solar charger or b) haven’t tried a full 100% USB charge since putting it on the solar charger after the not charging behavior appears, it may be worth a shot.

I’ll continue to monitor the cam and see what happens with my second panel when I get it set up.


Glad it’s working for you, we will have to keep an eye on it.

Pretty sure it’s the cam not the panel, I have 3 v1s and 1 v2, with 4 panels. I tried switching panels and the issue was always with the v2.

Hopefully it’s just a software bug, although I’m not sure if the v1 and v2 even have diffrent firmware versions.


You might have identified the culprit right there… Lol

There are hardware differences between the two models. Perhaps there should also be commensurate firmware differences… :man_shrugging:t2:

EDIT-1: Actually, I just checked my WCO v1 and firmware is v4.17.4.140. WCO v2 is Whether this is cosmetic or substantial is up for grabs.

1 Like

I actually have some new observed behavior to report here…

Last night, I turned on my folks’ WCO v2 (I’d been keeping it off to preserve battery) and left it so overnight. At some point, it basically went offline in the manner where it acts like it’s connecting but never does.

83% charge was the starting point and overnight it’s gone down to 0%. That is an abnormally rapid discharge. Not sure if there’s something wrong with a batch of these cams or the batteries, or the metering thereof, but this is not at all like I’ve experienced with WCO v1. The latter is always a very slow & steady discharge. Predictable increments & duration. WCO v2 acts like a wild child.

1 Like

Outdoor Version 2 firmware. (June 29, 2022)

  • Added support for time zones offset by half an hour
  • Fixed a night vision issue

Note: This firmware is halted because the support for offset time zones caused microSD card recording failure. We apologize for the issue and are working to resolve it.


Horse had already left the barn in my case. It must’ve been recalled/halted after I’d successfully applied it.

Either way, they appear to have an additional problem with batteries and/or solar panel charging.

EDIT-1: I’ll add here that my trouble began prior to updating to the most recent firmware. I was halfway hoping that firmware might have been the fix. In this case, it seems like it only introduced more problems.

1 Like