Solar Panel Not Charging Outdoor Cam v2

I have an outdoor cam v2 mounted on a shed near my pool. I also have the official Wyze solar panel 2.5W 5V connected with an unobstructed view of the sky.

My cam doesn’t appear to be charging at all. Bright sunny days with many hours of direct sunlight on the panel. I see the little lightning bolt next to the battery indicator on the app, as if the cam thinks it’s charging, but the percentage never moves. In fact it goes down a percentage or two every couple of days.

I’ve wiped off the panel. Unplugged all connections and reseated. Tried adjusting the angle of the panel. Also, the cam has no motion detection turned on; I only use it for on-demand viewing of the backyard. The cam reports 3 bar signal to the wireless base station. Firmware

Anything else to try?

Can you check that you have solar panel enabled in the cams accessory settings? That toggle should be on.

Also, if you remove the solar panel, does the percentage drop at the same rate? You can see what’s using the battery in the cams battery settings.

If those don’t work I would request a replacement panel, as it sounds like it’s defective.

1 Like

Thanks for the reply! The solar panel is enabled and toggled on in the accessory settings. I haven’t tried disconnecting to compare drain rate; I’ll try and see how it goes. I was also thinking of connecting my phone for a bit to see if it charged at all.

1 Like

I would also detach the panel and reboot the cam, then re-attach panel. If the camera battery has gotten low, charge it via USB first and then put it back on the panel. I’ve seen both of these “tricks” work.

I assume you don’t have a second cam but if you do, try swapping out and see if you get effective charging on the other cam. I had an outdoor cam battery fail randomly and I thought it was the new panel. (That camera charged ok on USB at first but not on panel. Slight voltage differences, I assume.)

I had some real finicky problems with my panels to start but some firmware update on the cams appears to have addressed that. I haven’t seen any issues in months. (knocks on wood)

Edit: Removed my first suggestion after I re-read the OP’s first post.


So I unplugged the panel from the camera. Same drain rate.

I tried your suggestion of unplugging the panel, rebooting the cam and re-attaching - voila! It’s now charged 5% already today in just a couple hours. I had tried rebooting the cam before, but it was still attached to the panel…guess there’s some magic that happens when it’s disconnected and then rebooted.

Thank you for your help!

1 Like