Watch SpO2 data to Apple Health

I just received my new watch 47 to replace the Band. I had the app previously setup to share data to and from Apple Health and all worked well. I have setup and paired the watch and can see the newly collected Oxygen Level data in the Wyze app updated today. When I reviewed the Settings/Privacy/Health/Wyze, I only see the previous Band categories of Active Energy, Heart Rate, Sleep Analysis, Steps and Walking + Running Distance. Nothing about SpO2. I have tried the “Remove Authorization” process and repeated the “Authorizes” process with no change.

Any I missing the option to share SpO2 data? Does anyone else see this option? Or this is not yet added to the app at this time?


18 Months Later… I registered right now, to post this same bug, which Team Wyze has left unfixed all this time! We need Wyze app to push our SpO2 (blood oxygen percentage) data, from our Wyze Watch, over to our iPhone’s Apple Health app (thru Apple HealthKit)!!! That desperate attempt to fix it by doing “Remove authoirization / Authorize” failed to get our SpO2 over to Apple Health! Wyze app is already sending many other health data from the Wyze Watch (Steps, Heart Rate, etc…) to Apple Health. However, our Wyze Watch’s SpO2 data is neglected, and that’s a bug! As proof, just look in Apple Health, “Blood Oxygen” says “No Data”. Listen up, Wyze app developers, your challenge is to fix this bug in the Wyze app for Apple iOS app as soon as you read this !

EDIT: log ID number 843028.

Other customers with the same bug, Wyze app fails to sync SpO2 data to Apple Health:

1 Like