Watch Firmware Updates Failing

The last info I have on this is from May 31, when I was told they are still looking for the issue. I do know it is being looked at and I check in with them about once a week for anything new.


I have the exact same problem going on with my 44 that I received yesterday. It appears to have no internet connection. I validated all communication, restarted the app, restarted the watch, nothing.

Hopefully the next app update will address this.

For not it is working perfectly on 0.3.90


I just received a 44 yesterday and also have not been able to update the firmware. Getting the oops screen. Powered off watch, reset watch, manual pairing, factory rest, Bluetooth forgetting, nothing works to update firmware.

1 Like

I have the same issue. I just bought the 44 watch. It says an update to the firmware is available. I accept it, It says “downloading firmware.” Two hours later it still says the exact same thing. I have rebooted the watch, rebooted my router, iPhone, and even tried updating firmware ALL. The other items that need updating did update. The watch just keeps saying “downloading firmware.”

Microsoft’s Ball of Death has discovered another haven!

Also having altogether 47 watch issue since the latest App update!? Has been permanently disconnected & it won’t connect no matter what I do!? Watch IS fully charged, I have unpaired & reconnected bluetooth, have restarted the watch, have force closed the app & cleared the cache etc…literally have done EVERYTHING besides factory reset which I shouldn’t be forced to lose my info & factory reset bcuz of fault of wyze NOT patching/fixing problems &/or updates??? I’ve literally NEVER had an issue like this with ANY Wyze product b4 & I’m REALLY NOT HAPPY especially considering this comment feed has been running for 20 days & we have been told “Wyze is working on it” but NOTHING HAS BEEN PATCHED/FIXED!? I’m basically wearing just a regular watch at this point which is UNACCEPTABLE & NOT OK??? WTF WYZE!?

Poor customer service Wyze Ticket 2042740

For weeks my two Wyze watches fail to update software. I gave it some time to see if it resolved. When it did not, I replied to the original service ticket. I got back a ticket closed msg saying that I should start all over again. Wyze service has really gone downhill.

[Mod Note]: Your topic was merged for better visibility and consistency in grouping similar issues. Also note that Wyze is aware of this issue and currently working towards a solution.

Fyi I very recently bought a Watch44 for both my wife and myself. My watch won’t update the firmware yet hers had no problem. She’s on Android and I’m on iPhone. She also didn’t previously have the Wyze app on her phone (was a new user to Wyze too) whereas I did (and it’s up to date - it has several Wyze cams registered and I’ve been a Wyze user for several years ).

When I removed the watches from both phones and added my watch to her phone, it had no trouble updating the firmware.

So this is possibly an iPhone-specific glitch. And/or a glitch with old user accounts. And/or a glitch with an account with prior registered devices.

That’s very helpful. I’ll give it a try.



Good information to help troubleshoot this! My mom–who has the FW update issue with her Watch44–did not have an old user account nor an account with prior registered devices. However, she does have an iPhone, so perhaps it’s an iPhone issue.

Finally able to update my 47 this afternoon using my iPad. Yay!

Was this issue fixed?

Ref: Wyze Watch 47 - Raise to Wake stops working and starts working when left on a table overnight - #3 by jain.aditya

This should have been fixed with the Android ‘Nearby devices’ issue, that was stopping the firmware from updating.

1 Like

I think the problem is related to 47 vs 47c.

47 successfully updates to the latest firmware, 0.12.49.

47c is stuck on 0.12.28.

Is there an internal difference between 47 and 47c that requires separate firmware?
If not, can 47c users reset their watch, add watch as 47 and load 0.12.49 with no issues?

I will have to check on that, I know when this issue came up originally we did have both watches failing fw upgrade.

1 Like

I just wanted to chime in on this. Since day one. I have had issues updating the firmware on my Outdoor V2s. I am a network tech, I run a custom AI Mesh network. I am knowledgeable in regards setup. So first off this is NOT a network issue on my side. That and all my cameras work flawlessly.
But as always, Whenever there is a firmware update, they always FAIL. I can literally put the V2 next to the hub and it still fails. I find that if I do so at 3am, then 9 times out of 10 it will update.
I don’t think this is an android issue, or a version issue. To me this is a Wyze issue on their side with their servers. Another example of this is the Wyze chat. I can type a complete sentence and watch it for 30 seconds delayed type out. This unreliable firmware update issue has to be addressed. I spend far too much time trying to update my cameras, when it should be happening fast and without issue as long as the network on my side is up to speed.

That may be, but this is a watch topic and this issue has been resolved for quite some time now.

Finally, after my mom arrived on the west coast to visit me, I was able to upgrade the firmware on her 44mm watch for the very first time!
I did notice that her watch time was still on eastern time when she arrived until we resynched with the Wyze app, so I’m a bit disappointed about that (perhaps the FW upgrade addressed that?). She asked me why the iPhone has the correct time, but not her watch, which is a perfectly valid question, especially for an 85 year-old woman. I just told her that technology isn’t perfect, but it gets better over time (what else could I say?).

Ultimately, I’m not entirely sure what the original issue was since my previous attempts to upgrade the FW were at her residence on her network (cable modem on Xfinity). However, on my network here, the upgrade was successful on the first attempt.

This same issue is occurring with our Wyze bands.

Please inform your team thanks.

Unfortunately I hate to say that the band is no longer being updated by Wyze. It has reached its end of life.
The last firmware update for the watch was almost 1.5 to 2 years ago.
I love my band but Wyze hardly ever cared about it.
I think it was more of an experiment for them then an actual product.