Watch battery stuck at 70%

Had my wyze watch for a couple months and now the battery won’t charge past 70%. Anyone else experienced something like this??

Welcome @agageumr!
I haven’t experienced this. I’m thinking your watch might be charging past 100%, but the watch is only indicating 70%. Have you noticed if the battery life has been shorter or the same as it was when the watch showed 100%?

Try holding down the side button on the watch to restart it.

1 Like

are you seeing the 70% showing on the app on your phone or is that directly from your watch?

also if you are looking at the percentage on your watch, is that during it charging or after it is removed from the charger?

my rational in the question is im hoping you are looking at the indicator in the app after it does a sync. if it is not syncing completely it may only show the last number it has stored. I’m hoping that’s it.

but if its from the watch itself, I have some ideas there too that maybe might just change something ( hopefully) if not. I have an idea of what it might be in that rare case.

please update us soon :slight_smile:

1 Like

The 70% was on the watch face when plugged in. The weirdness continues this morning… it randomly turned off this morning and wouldn’t turn back on so I plugged it in again and the face doesn’t come on at all. BUT it is now randomly vibrating ~20sec at a time while plugged in and when it’s vibrating the screen sometimes show a very faint WYZE logo background. I can’t get it to turn on and it doesn’t show the charging screen at all. I think it’s in a pretty bad place…

Have you tried restarting the watch?

Assuming you mean by holding the button down? If so, yes but nothing happens.

Small update. The watch eventually showed 70% again on the watch face while plugged in. Not sure when this started as I left it plugged in all morning. It also continued to randomly vibrate for ~20sec at a time… Eventually the watch face went black again so I unplugged it and tried to power it on to no avail. At one point later in the evening I walked by my office and saw the watch powered on with the “WYZE” logo displayed. I tried to do something with it, but nothing caused any change.

At this point, I think it’s pretty much shot and I need to just contact customer support.

You may want to contact Wyze Customer Support about this issue!
By phone: (206) 339-9646
Or online:
Monday - Friday 4 AM – 8 PM PT

Saturday 8 AM – 4 PM PT

I happened to see this and had a partially similar experience after firmware update 0.12.41 a couple months ago. My WW47 displayed battery-charge got stuck stuck at 41%, but none of the other flaky issues you’re seeing. Mine fixed itself after I charged it up to and (suddenly?) past 100%, and subsequently the battery level decreased at a normal rate with use.

None of the other issues you mention. Have you tried just leaving it on its charger for a few hours, or click, then holding the button while it’s charging?

In case you haven’t actually seen this, if you do get to the Time display and then hold the button in for a few seconds, the watch should show 3 lozenge buttons - Restart, Shut Down, and Cancel. If you can get it to Shut Down, it might clear the bug. A battery-drain shut down would take perhaps 3 weeks, but much shorter if it keeps vibing. A restart from a full shut down might get it to work again…

Hopefully the support folk can get you going more quickly. Good luck!

Thanks all for your suggestions and support. I did contact Wyze support and they gave me a couple ideas which got the watch to charge all the way to 100%, but then it just kept restarting with a wacky flashing screen and the annoying periodic charging. I took a video for them, and they sent me a new one and I’ll send the old one back and maybe they can figure out what happened. Great support as always!

1 Like

Glad it’s working out for you!