Watch Alarm Not Working

Anyone had issues with the alarm on Wyze Watch? I got the 44mm version this past week. I set an alarm for 6:00am, to repeat every weekday, but it has yet to go off. I double checked that the alarm is turned on. There is also a “snooze” option when setting the alarm. Not really sure what that does, but I’m guessing it gives me a snooze option when/if the alarm ever goes off. Am I doing something wrong?

I just tried using the alarm function on my 44 after reading your post. I had the same experience.

Thanks @kirk_fraley . Glad I’m not the only one.

Same here. I’ve set several alarms on the Watch 44. None work.

This morning the alarm worked. I didn’t do anything to it or the settings yesterday. ???

Yup! :partying_face: :partying_face: :partying_face: mine works now as well. Must’ve been a stealth update last night. Well done Wyze. Now I gotta play around and see what else is different???

Still some strange things with the alarms. My 6am alarm continues to work. This past weekend I set a 7am one time alarm and it never went off. The following day an alarm went off at 7:20am, but I didn’t have one set.

1 Like

Mine works the first time I set it for everyday. Then, the next day, and after that, it no longer goes off. I tried adding other times and I get the same thing: it works just once. The second day it went off at 4:10 pm (it was set for 4:00 pm).

Just did an update to version 0.3.68 and still have problem.

Mine have started working in the past few days as well.

Mine is at 0.3.65…app says I’m up to date. Is yours a 44?


I have several alarms set. Every day, they go off 10 minutes later than the previous day. For example: the alarm is set for 4:00pm, the first day it goes off at 4:00pm, the next day it goes off at 4:10pm, the next day after that it goes off at 4:20. This happens on all three alarms I have set. I’m at version 0.3.68.

I’ve gone back to wearing my band for now. It works a lot better and the display, although smaller, is a better image. I hope this won’t be like the scale and never gets fixed.

My alarms have stopped working. Seems it worked for about 1 week, and this week (or so) has returned to never alerting.

alarm still not working on my 44 mm
some time it decides to work some time is it come on 10,20,30 minutes later
its like its going it to snooze instantly by itself
but works fine on 47 mm

ok its not just me yes, it fills like it snooze for 24h and 10 min instead of 10 min …

Maybe the snooze bit is being set. That was the first thing I thought of as it is an offset of a multiple of 10 minutes.

My husband upgraded to the Wyze Watch 44 from the Band. He too has been having consistent problems with the reliability of the alarm. The Band’s alarm was very reliable and he used it as his morning wake up alarm, This was great as the buzzing woke him and didn’t wake me; I get up at a later time than he does. The Watch 44 is so unreliable for alarms that he has had to go back to using an alarm. I sincerely hope Wyze addresses and fixes this alarm issue soon.

I have an alarm set, not to wake me, but for other daily tasks. I was going to upgrade from a Band to a Watch 44 myself, but until the issues are fixed on the reliability of the alarms I don’t plan on making the switch.

That’s one of the reasons I switched back to the band. Not perfect, but mostly functional. I feel that’s the most I can ask for at this point. I hope this isn’t going to be like the scale. Mine’s gathering dust because they don’t update it’s algorithm. It might be that the alarm is something they can’t fix with an update. Anyway, the band has the Alexa connection that the watch won’t ever have (no built-in microphone). And the band’s alarm has certainly saved me a few times when it was the only alarm I set that woke me.