Watch 47: Repeatedly Displays "Device Paring" message

Roughly every 10 minutes the message “Device Pairing: Your messages are available on the device you’ve paired” is displayed on my Watch 47. Started recently, perhaps coinciding with the release of Android 13 on my Pixel 4XL phone, but not entirely sure. However, since this message does NOT show in the notifications on my phone I believe it is related to something on the watch. Have powered the watch off/on. Have powered the phone off/on. Note that my watch is definitely paired with my phone and text messages do get displayed on the watch, but I definitely don’t need the watch giving me this message every 10 minutes. Any suggestions on how to resolve this issue will be appreciated.

Watch 47 running 0.12.49. Wyze App v2.35.0 (b80). Pixel 4XL running Android 13.

1 Like

I am sorry this is happening. Can you check your Android permissions and make sure Wyze can access ‘Nearby devices’.

Thanks for your reply Jason. Just checked the Wyze app and it does indeed show “Nearby Devices” as a granted permission. Beneath it says “Accessed in the past 24 hours”.

Under Android 13, you may need to allow Location access (Allow all the time) and also Use Precise location (may read “Access Fine location” depending on your device UI).

Thanks for your reply. I just checked and location is allowed all the time and precision location is turned on.

1 Like

At that point I am out of the limited troubleshooting I am aware of and would recommend contacting support.

Wyze Support

(206) 339-9646
Mon - Fri 4am - 8pm PT
Sat - Sun 8am - 4pm PT

1 Like

Thanks for trying to help.

The exact thing is happening to me as well. Hadn’t connected it with the Android update, but seems to coincide.

Same issue here, seems to coincide with the Android update…

I am experiencing the same issue since upgrading to Android 13. The app does have Precision Location and Nearby Devices enabled.

For what it’s worth: I just applied the first Android 13 patch/update and the problem still exists. Still not sure whether it’s an Android 13 problem or something that Wyze needs to fix.

I will add I’m using a Pixel 4a… Had to turn off notifications in the wyze app to shut the watch up…

I contacted Support about this issue and they said it’s a known issue and they are beta testing a fix. A few days after that I noticed the Wyze app got an update but that didn’t fix the problem. It would probably help if all of us with this issue called Wyze support.

1 Like

If they gave you a ticket# I’d be happy to contact them and add onto your ticket.

I came here looking as I’m having the same issue. I’m about to just give up on the watch. It’s even doing it throughout the night waking me up.

It was an affordable watch, and has served its purpose well. Maybe it’s just past its prime.

I tried all of the suggestions above and the problem persists.

Same situation here. Anyone figure out a solution or are we all just waiting on a fix to show up?

I talked to support last week. We are waiting on a fix.

I just disabled notifications for the watch today. It’s a crappy solution, but at least I have a watch again.

Wyze Ticket 2408426

I spent some time last night with support and referenced that ticket number. Just received an email from them saying “Our team said they are aware of the issue and advised us to submit an app log for this”. So, I just submitted a log file and we’ll see what happens. Apparently they are having difficulty understanding and fixing the issue.

1 Like