Watch 47: Repeatedly Displays "Device Paring" message

Well, after exchanging a few emails with “support” and sending multiple logfiles I just received an email from support saying the following:

“This request will now be closed as we are unable to offer any further troubleshooting. Please keep an eye out for future app and firmware updates. If the issue persists after those updates, please continue to submit logs so that our engineers can continue improving our devices”

I understand that closing tickets looks good on their “closed ticket” reports, but how do they justify closing a ticket when the issue is still unresolved?

Thank you for your efforts, the ticket should only close when it’s resolved. My watch has this issue and also a portion of the screen has stopped responding to touch. It is now resting in a drawer and I bought another brand. Some of my neighbors bought wyze watches based on my advice, I need to check with them to see if they are mad about that and if they are having similar issues. For those folks that end up here with the same problem, I’m using an unmodified, stock, up-to-date software Pixel 4A. Thanks again Dietzgw.

So, I “fixed” the problem. Note: This is on my Pixel 4XL running the latest Android 13.

I had been blaming this on the Watch 47 because the message was only showing up there, and not on my phone. However, yesterday I happened to be looking at the pull-down notifications page on my phone when the message popped up on my watch and, to my surprise, popped up on the notifications page of my phone. Even more interesting, as I was staring at the message on my phone, after about 10 seconds it disappeared! Since the message pops up on my watch every 10 minutes or so, I waited for about 8 minutes and then opened the notifications page on my phone and waited. Sure enough, in a couple of minutes the message popped up on my watch and on my phone. I managed to grab a screen shot of it before it disappeared, and when I looked at it more closely it appeared to be coming from “Messages for Web” and not the standard “Messages”. With that as a clue I went into Settings for Messages for Web and turned off notifications and VIOLA! No more annoying “Device Paring” messages!

On my phone, here is what I did:

  1. Open “Messages” (yes, the standard Android texting app).
  2. Tap the “hamburger” (3 stacked lines) in the upper left corner.
  3. Tap “Device Pairing”.
  4. Tap the “stacked 3 dots” in the upper right corner.
  5. Tap “Notifications”.
  6. Turn off “Show Notifications”.

Presto! No more annoying notifications every 10 minutes! It appears to me that this is a “bug” that was introduced with Android 13 and maybe, just maybe, Google will fix the problem. But until then, this will stop the notifications.


Great detective work and solution! Thanks !!!