Vacuum path to selected room is off

I’ve had firmware 1.6.113 since it was released as beta and everything has worked ok. I ran a quick map a month or two ago and I’ve been using that map since.

Today I ran another quick map for the giveaway that Wyze is doing. The map looks great, I added my no-go zones and sent it off to the kitchen. You can see where it went in the office and entry. It bobbles around that area, bumping into the piano and a door for a good 2-3 minutes before going back the way it should into the kitchen. I’ve also sent it to the laundry room and living room with the same thing happening.

Any ideas on why it’s doing that? I have no clue why it would go the opposite direction and start bumping into stuff, only to turn around and go the correct way eventually.

I’m using an Android phone on version 2.19.14

I just reset the map and did another quick map, setup the rooms and no-go areas again and it’s doing the same thing. Just fumbles around for a bit in the office area then decides to actually go clean the room.