Vacuum not sticking to scheduled rooms?

My vacuum will run at scheduled times, but it doesn’t stick to the rooms I assign it at scheduled times. For instance, I have it scheduled to run in the dining room and play room (2 adjacent rooms) at 9pm. It will vacuum those rooms and then start trying to vacuum other defined rooms like the kitchen or living room, when I don’t want it to run in those rooms at that time. Anyone else having this problem, or know a way to try to correct it?

had been working fine but today i used an old schedule at a new time to clean two rooms, it cleaned only one. i set a new schedule to clean the room it missed, but it recleaned the same room again, not the one designated. weird.

workaround is to not use the scheduling feature, just select the Clean button on the main screen. Of course add virtual walls first to block anywhere you dont want to clean. Worked for me to clean both rooms i wanted to. well, at least it has worked once. we’ll see. Using the manual clean instead of schedules is okay with me since i have to tie back some long curtains anyway.

On a side note, it seems to me that the first time i cleaned after the initial mapping, using the manual clean button gave me the option to select rooms to clean. now it does not, that option is in schedules.