V3's brick after 6/14/21 update

Three V-3’s became bricks after trying to update to the firmware released June 14, 2021 and it happened again today! A mssg said update failed and to reboot cam. Went back to the cam on the app and it said offline. Did absolutely everything, very familiar with these cams.

Primary issue is V3 will never display again a flashing red light in order to reconnect it. Left it plugged in with a solid red light for a couple hours even and it never flashed. Last resort was to delete it from app and tried again an hour later. No flashing red light, a total useless brick. This happened to all three of my V3s because I selected update all. All were kicked offline and couldn’t display a red flashing light to reconnect.

After explaining to Wyze rep, she recommended if cameras are working well then do NOT install updates. Well that’s lovely, get to deal with pop-ups saying there’s an update available and the fear of an accidental click on update links in different places. Because once it even starts the cameras are doomed. Few weeks later I received the three replacement V3s. I got help to change out ones I can’t access myself, connected them easily but obviously didn’t update them. Tired of the reminder pop-ups, today I decided to just try downloading the update to the cam I could access.

AGAIN it said update failed, reboot the cam. (This has never happened with my multiple V2s, 3s or outdoor cam in over two years). Unplugged it a few minutes, hit retry update and it continued to say reboot the cam instead of trying the update process again. Tried many times.
App showed the cam as offline. Holding setup button in for a minute also did nothing again to reset it like with the last three. I deleted this one from the app and sure enough, couldn’t reconnect it because it won’t display the flashing red light. Currently it’s been plugged in about an hour and the red light stays solid after pressing setup button. I just held it in 10 secs and no chime, no ready to connect.

Now I have to ask them to replace one of the three they already replaced and have the other two constantly pop up there’s an update available. Worse there becomes a point where I think Wyze has said you have to update for cams to work with the app. It’s like why even have them when you can’t exchange them after a year but maybe required to download the update. This seems like a serious problem yet there’s been no announcements. Does anyone know why this is happening? Have updates bricked your V3’s and what did you do?

Thats the same problem with me. I see some folks had success manually installing the previous software version but I had no luck. Waiting to see if this issue is resolved before I even install the replacements as I see reports of the replacements getting bricked as well.

1 Like

Fortunately for me, my V3s updated without a problem.

If these were a few incidents, I’d dismiss them as some user error, but considering the volume, this is a real problem – for Wyze.

For a long time now, Wyze has depended on beta testers solely, to test its releases. It has no real in-house testing despite claims to the contrary.

A few developers testing on their own before checking in their own code, that’s not real testing.

In addition, there seems to be no code reviews prior to code check-ins. How else do you explain previous fixes disappearing in later releases?

That is really an sindictment of Wyze. I hope they do not become the cheap item that turn out to be unpolished and more costly in the long run. I have cameras from VAVA, Liitmor and Lutron caseta switches. Although they do not have the bells and whistles, almost of the latest Wyze promises, they have been rock steady and 100% reliable. Such a joy to use the others. Oh and don’t get me started on wi-fi range. Why can’t wyze have the range of these products.

1 Like

@WyzeGwendolyn and ideas to help us solve the issue here? Don’t want to brick my replacements


Thanks, that’s an idea to get an earlier app version but could be self-defeating. Like if they require a current version when cams are a year old you’d have to brick or trash them. Idk where to dl an old version tho and can’t reset phone to an earlier date.
Thanks to who tagged Gwen, hopefully she’ll help, this is terrible.

Release Notes & Firmware – Wyze

^^^here for old Firmware. Easy to flash back to earlier firmware. Don’t think you can rewind the apps.

Thx. Are you saying reinstalling the update prior to 24 June will reset the app and the camera will connect again?

Did you get them to work?

The response was to revert the firmware on the camera not the app. No way I know of to revert the app on the phone.

Sorry, just saw your reply. It’s been a big saga but no, I didn’t get the one replacement that I tried updating with June’s firmware and bricked going again. With the other two V3 replacements I’ve been careful to dodge update pop ups.

Spent a long time with customer service getting some slightly different information. Ultimately I tried the manual route on it. Bought a micro SD card and adapter and was super careful following instructions but cannot get the purple light when plugging in and holding setup at the same time–stays solid red.

Then a couple days ago a CSR said this was a well-known and common problem, June 14th update bricking V3s, and he believed the next update would include corrections. They’re sending a replacement again but I’m nervous about even installing it since it might install the latest firmware with the infamous June 14ths.

If not and it just says new firmware available I won’t install it. Then guess we just hold our breath when installing the next update. If that one bricks V3s I’ll have to return them. It’s become an enormous amount of manpower hours maintaining many different devices and I feel like it’s time to find a better way if there is one. Had to ask them to mail the return label but don’t even get me started on my printer!

Purchased five cam3 at end of April 2021,

One got bricked while applying the firmware upgrade to (resulting in an Amazon replacement within 60 days with restocking fees!!!).

We are now in august. All cams have been running since end of june…

Now we are in august and three cams (including the replacement camera) are bricked!?!?!!?!!?

Absolute trash.

It’s almost shocking actually that it’s been 2 months since the June 14th update bricked so many V3s and not a single word about another update that’s safe to download. Csr’s kept saying technicians are very aware and working on it at the end of June.

Sounds like you got lucky that June 14th update let a few of your V3s run this long before bricking them. But yeah, anytime you have to put so much time, effort, work and worry without a word about a fix is pretty frustrating. Have replacement V3s that I still have to avoid updating and don’t know what will happen with them. Charging a restocking fee might be another way Amazon pushes prime membership, smh.

One out of six bricked for me. I have felt the Wyze products take a lot of time. In years they will probably talk about how much effort went into making things work in the old days.

As some know there were the days when the car owners manual expained how to set the clearance on the valves, now the manual tells you not to drink the battery acid.

I am curious what size of SD are you guys using? Did your cam brick while using 32Gb SDs?

Three of my V3s were bricked by June 14 update. Only one had an SD and it was a 32. I chose the update all option, won’t again. Will update and test one at a time if and when they develop a firmware update that specifies it’s safe for V3 and they discovered and corrected Junes’ update issues.