V3 will only update firmware manually

I have a v3 cam that is out of warranty. It was initially mounted outdoors and due to this issue was replaced with a new v3. I now use the problematic cam indoors because it is easy to get to.

This particular cam will not update firmware online. This has been happening for well over a year now. I was hopeful that once I manually updated it one time, subsequent updates would work over the network. Unfortunately this is not the case.

Every firmware update that has come out for (at least) the past 6-months must be installed manually. If I try to install it via WiFi the cam goes offline and will remain offline until power cycled. Once power cycled the cam works properly again, but never updated the firmware.

Has anyone else bumped into this? What was done to correct the issue long term? I own several v3 cams and only have one that displays this behavior. It is also worth mentioning that I placed this cam on someone elses WYZE account and it wouldn’t update properly for them either.

This problem started when trying to update the camera from to Ever since that release all updates have been performed manually. I say “well over a year” above, but its actually coming up on a year.

Just a shot in the dark…have you tried different power supplies? I’ve seen some strange things here that were cured by that.

1 Like

I have not run into a persistent issue like this. When I have had issues in the past, I did the following and tested:

  • Unplug power from Camera for abot 15 seconds, plug it back in and when it is fully loaded, try the FW update. Do the FW update from the Camera Side itself and not from the Firmwarw Update Page

  • Clear Cache from within the app by starting the app, go to account>App Info>Clear Cache. Then Back out to Account Page scroll to the bottom and sign-out. Make sure you have your credential and 2FA (if activated) to log back in. Then close the app down. On Android, long press the Wyze icon and choose app info, do a Force Stop, then go to Storage and cache and clear cache from there. Reboot the phone. Once back up, log back into the app - NOTE: the camera icons will be missing. They will come back when you live stream again. Now try the update from the Camera, Settings area and see if it updates.

  • Restart your Router. I have had issues where this occurred until I rebooted my router. Even though other devices were working, the WiFi Streaming was having issues.

Just a couple of things to try,


This isn’t normal in my experience. You said the cam was problematic when outdoors. Any chance it is just a malfunctioning cam, like intermittent network reception?

I’d try @WildBill’s suggestion of a new power supply – at least that is a very easy solution to test. :slight_smile:

Thank you for your reply and suggestion. Yes, I have tried at least two different power supplies. Unfortunately that did not resolve the issue.

Good morning and thank you for your reply. I have tried bullet points one and three multiple times. I’ll give bullet point 2 a try the next time firmware is released.

1 Like

Curious if it works for you as it has for others. I have made it a habit to perform those steps when a new app comes out. Especially when notifications seem to be an issue.

Thanks for your reply. The camera works wonderfully. No problems with anything other than updating the firmware; it has to be done manually. I can live stream from the camera for 15 minutes without an issue. I can view playback for 15 minutes from the uSD card without a problem. Its a strange issue for sure.

1 Like

What was this statement referring to if it works wonderfully? Maybe I misinterpreted.

I have 2 like this. I was originally upset but now that I have had 3 die completely from firmware updates I am just happy they still work. Came online today to vent at another one failing with this last update and started to notice all the other users experiencing the same thing. Makes me wonder if this is their big plan and how they keep sales high. >< smh but in all honesty I know they are not too expensive to replace but when you factor in all the time and hassle those expensive ring cameras that I have installed and not had to do one thing with and have been trouble free and work for their over 3-4 year life so far become much more attractive. Not to mention I’m still waiting for my 3 in 1 sensor to go with my thermostat…


Hmm, let me put it in other words. The camera has zero issues and works wonderfully with the app, notifications, playback, live stream, etc. The only problem this camera has is in the title of this thread. Therefore I doubt it has anything to do with connectivity issues. Also, this camera has had the same problem on two different accounts/physical locations. All functions work other than the automated firmware update.

I have the same problem on a couple of v3 cams, while others update normally.

It is odd. In my mind if a cam is having problems with the automated process, performing the firmware update manually one time should resolve the automated process moving forward. This is not the case for my problematic camera.

Every firmware release requires a manual update for this cam. Should I attempt an automated update the cam hangs and will only come back with a power cycle. I look forward to the next firmware release such that I can try the suggestions offered in this thread.

If anyone else has ideas please feel free to chime in.

1 Like

I have the same issue. very annoying. can only manually update Wyze Cam V3. all auto in-app updates failed. After the failed attempt, the cam needs to be power cycled.

Thanks for sharing. I’m sorry you’re having the exact same issue, but I’m glad I am not the only one. How old is your cam by the way?

about 15 months old

1 Like

That’s about the same age of this cam. Unfortunately I can’t determine the exact date within the app as the cam has changed accounts since the initial activation.

New firmware was released today and like clock work, this cam would not perform the automated update. My other five v3’s had no problem. I’ll try the recommended steps above, but honestly, I do not have high hopes and might just cut to the chase and update it manually yet again.

I did submit a log to WYZE this time: 553789

Obviously I couldn’t submit that log until the cam was power cycled after being hung up from the attempted update. Not sure that any log is going to help, but this new firmware might resolve that based on the release notes? Not sure…

There was an update today? I don’t see any being asked of me to download.

Wyze Cam v3 Firmware (April 25, 2022)

Wyze Cam v3:

  • Improved logs for accessory product firmware update failure
  • Adjusted the audio priority for camera features
  • Fixed an image quality bug that produced a strobing effect
  • Fixed a bug that caused a reboot after pairing Wyze Cam v3 for the first time

Wyze Lamp Socket:

  • Improved lamp socket response time

Wyze Cam Floodlight:

  • Reduced face overexposure when the floodlight is turned on
  • Modified the default lighting time to 30 seconds
  • Fixed a bug that caused false detection when viewing the live stream

Just a quick follow up to let you know that I stepped through all of bullet point number two. The only thing I did above and beyond is powered off the camera prior to the procedure. After rebooting my phone, I powered on the cam and attempted to update the firmware from the cam itself… No joy.

Time to pull the uSD card, copy the latest firmware to the root, and update manually.

Device Details:

Failed update:

Post failure: