V3 Stuck on Firmware

Hi all, I have a half dozen V3 cams. All have updated to FW

All except for one that is. It seems stuck on the update from earlier this year. Checking current FW shows the older FW version and “Everything’s good! Your camera is up-to-date.”

So far I’ve tried to update it individually, update multiple cams, power cycled, and did a delete/factory reset. It still isn’t interested in updating and doesn’t see any new updates available.

Thoughts? Thanks in advance for any help.

You are not alone and count your blessings :rofl:

Check this thread, also there is another response by a Wyze Team member, but I can’t find it. Just wait like the rest of us. BTW, is the latest know FW with no issues.


Here is the official word from Wyze JasonJ.


WyzeJasonJWyze Team


I see many questions regarding cameras stuck on The reason some are stuck on is because we released, this firmware was replaced by which was halted due to an event recording issue. is to fix the event recording issue with and was only released to cameras that were already on 4.36.10.x.”

1 Like

Yeah, I’m seeing where others are having the same issues now.

I guess they tried to push a new FW, it presented some problems, and everything else is stuck on for now.

I will say that the “new” firmware seems to work fine for me, but it did turn off people detection on all my Cam Plus Lite cams. The UI looks a little different, but I was able to turn people detection back on.

For now this is the last stable version and I am okay with it.

Not an expert here since I don’t have that version, but if I were to guess, I would say that People Detection was overhauled in expense of UI redesign. Again, just my ignorant guess, but I’d rather have a stable FW than a cool GUI.

My 2 cents

Are we still all stuck on
all my V3 cams are stuck on this even now in 2023
(no update available etc)
i had a reply from wyze saying 10.xxxx was pulled due to problems but surely that cant be now?
anyone managed to update via App to a 10.xxx
Fanky :¬)

hi mate, all my 8 V3’s are also stuck on the .139 firmware and i cant get any updates on them. I have deleted camera and reset them/added them back onto my app but they still show as up to date at .139.

I’m staying on .139. If you really feel the need to update the firmware you can do it with an SD card 32GB or below: It will take a while to do all 8 cams.

I would stay on I have one v3 on just for testing and this firmware has the most bugs for me.

Here is info on Beta testing if you are interested.

Count your blessings. X.139 is the stablest (don’t know if that’s even a word) firmware. I would roll back in heartbeat if I didn’t have to climb ladders and drive hundreds of miles.