V2 firmware released to the public!

Same for me. I have to clear the cache again when I get new notifications for the new videos to work.

I’m having the same issue videos or sound with zero clips, cleared the cache nothing, using android app 1.4.43 and Galaxy s9. I want to flash it back to the previous version but can’t seem to find the location of the firmware. I also want to add that the two-way radio needs to be fixed so you don’t hear your voice when talking to someone its and echo feedback.

We released our new Android app 1.5.42 that fixed this issue. Please update to the latest app. :slight_smile: Let me know if it doesn’t.

Seems to be working thank you!

I was hoping the update would allow me to be able to kill the IR light, and leave the camera in IR mode… Darn!

Thank you for the speedy fix! The update appears to have fixed the issue.

The latest Android app seems to have fixed the issues. Thanks for the quick turnaround .

Dont know what happened but I cannot connect to any of my cameras, error code -90 (even after power cycle them). Any idea on how I can recover?

Two of my cameras won’t update to the latest version, and I’ve tried power cycling them. Any suggestions?

Ive experienced the same issue and submitted a ticket for it

If your Android OS is not 5.0 or 5.1, I recommend you update to our latest Android app 1.5.42. The issue should be fixed in that version.

If your Android OS is not 5.0 or 5.1, could you try updating to our latest Android app 1.5.42. The issue should be fixed in that version.

What is the status light on the camera? If power cycle doesn’t help, I suggest performing a factory reset. Instructions can be found here.


This might also be useful!


What happened after you clicked ‘Update’? Did it go through 100% but prompt ‘failed’ message?

After updating the Android app and clearing the cache one more time the video notification loading has been flawless. Thank you!

Yes it went through 100% and then I got the sad face with the “Upgrade failed” message. I have not yet tried the factory reset.

Did the latest firmware update also increase the sensitivity of the sound for sound notifications? I noticed I’ve been getting a lot more somes alerts now. Also I can hear the lighter sounds when I used to not be able to.

Hi. Prior to the recent app and firmware updates, my WyzeCam2 worked pretty much flawlessly. Since the updates, however, it’s become almost unusable. It frequently gets stuck on ‘Connecting camera 1/3’ or ‘Authenticating 2/3’ resulting in ‘Connection failed’ with error code 0 or 27. On the occasions the camera does connect, live streaming is very juddery even on 360p - before it was fine on HD. Camera WiFi signal strength varies between 54% to 85%. I’ve tried power cycling and factory resetting the camera, restarting my router but to no avail. Are these know issues or is it possible to revert to earlier firmware?

will version 1 cameras have a firmware update so there is an image on the notification list like the update did for version 2?

same here! where can we download the firmware versions?