V2 Cam events no longer load from cloud

Pretty recently my V2 cam is no longer able to pull down events from the cloud. I still get alerts around motion or sound - when I have them turned on. I can see the cam live and it’s all up to date. Not sure when this happened, but seems fairly recent.

Any thoughts or suggestions on how to fix this?

Are you getting the error in your app when trying to view events? Is it happening to all events, or just a few?

Try power cycling the cam, and see if new events are viewable

Only the events for that camera. The other cams (outdoor, doorbell, pan) are fine and I can see their events. I’m away so I can’t physically power cycle the cam.

Are you getting an error code? if so, what error code? Any vital info like that is important for troubleshooting, and comparing to other issues.

Have you contacted Support? The forums is a great source of knowledge and helpful community members, but the official avenue of assistance is by contacting Wyze Support.

Well… a restart seems to have fixed it for new events. However the events from yesterday and early this morning (before the restart) I’m still unable to access.

No error code. It just starts to load and then spins and spins without ever loading. Odd, but not the end of the world.


Restarting the camera is definitely NOT a long-term fix. We have 8 cams in two different cities and have been having this same issue for months - ONLY on our V2 Pan cams.
We can restart and then the events load fine…for what seems to be a random period of time before we’re back to the spinning wheel. AND restarting only fixes new events. It does nothing to fix those, which would not previously load.

I have the same problem. The last code update was supposed to fix this and of course it did not. This issue has been at least six months for me. I have a rule that restarts the V2 cam’s daily and V3 weekly. The V3 hangs once in a while and the only fix is to unplug and plug back in.