v1 Firmware issues

Hi, we just released v1 beta firmware V3.9.3.56. We are hoping this to be the last beta before pushing it to public. Please use this thread to track issues. Thanks for your help!

Changes include:

  • Fixed a networking issue which caused camera disconnected
  • Adjust video buffer management to reduce chances to get stuck at 3/3 step
  • Increased sensitivity for motion alert (V1.3 app only, no change for V1.2 app)
  • Added logging for some failure code path

Suggested test areas:

  • Overall connection success rate
  • If connection gets stuck at 3/3 step
  • Test new motion sensitivity level

Thank you, Rick!


I upgraded to 3.56 on both cameras last night and I just got a failed -90 on one of them about 15 minutes ago. I emailed the log to Max.



I also should have mentioned that it was so strange when I was prompted last night for the firmware update on that camera it said new firmware 3.56 click to upgrade. It then proceeded to upgrade and when it finished it said successfully upgraded to 1.100? or something like that I should have written it down. Next, I exited the app and reloaded and sure enough it was the wrong firmware but it prompted me again to upgrade so I clicked the button again and the process started again, and the second time it upgraded to 3.56. I never had this problem with the other camera. The one that generated the -90 was the one that went to 1.100 or whatever earlier firmware got written to the camera. Maybe the log will have the details…

With the current firmware I wanted to also note it appears the sensitivity was bumped up quite a bit as I had to turn it down by like 50% of what I had it set at as I started to get bombarded with notifications but that seems to be working much better.

I updated 11 V1s to this morning. This afternoon, 7 of them are only showing one frame every three seconds when connected from outside local network. I power cycled one of them and it returned to normal.

  1. Two camera....
    1. One need to upgrade the firmware three times before it get upgraded
    2. The second camera took five five times before it get upgraded.
  2. The motion alert appears to be broken again. Getting motion alert every few minutes from both camera before the upgrade.
The wireless connection has been stable and connected for over two week on the previous version.

Alert with zone enable was working fine with the previous version.

Disable alert and re enabled, problem remain.


Version 3.58 is a test version that we have internally. I don’t know how it was pushed accidentally to your camera. I double checked that it is not prompting for 3.58 now. Upgraded to 1.100 is weird too. We had 1.102 quite a while ago but 1.100 is another test version. It doesn’t even exist on the list anymore. Can I call you the ‘lucky’ customer for Wyze? :slight_smile:

Given it only happened once I would temporarily let go with the issue. When it shows up more we will keep a closer eye on it. Thanks for letting us know it!

Just upgraded to the V1 firmware along with the app version 1.3.113 on my Oneplus 3 phone. Happy to report that the two biggest problems I was having seem to be resolved. I am now getting push notifications on the phone and I can delete recorded motion alerts from the phone and they stay deleted. I haven’t played with any of the new features yet but I’m very glad that all of the basic functionality has now been restored. Thanks to the dev team for getting this resolved.

No connection problem in a while, very reliable. Notifications work great. My only problem related to that firmware is the sound detection. Got it set to 15 and it is still detecting pretty low volume sound.

It would be nice it there was something to help you adjust the sensitivity. There is no way to see what the camera is hearing. It would be nice if there was a calibrate mode, where it would display a moving volume graph and the slider would move an “alarm threshold” horizontal line up and down so you could make a sound at the level you would want to detect, then adjust the threshold to that level.

As it is, it is a trial and error with long waits between.

I also wonder if there may be a difference it what “sensitivity” means to whoever is writing the code. To me, low sensitivity means “ignore low sound”, but someone may be coding it as if “low sensitivity” means “sensitive to low sounds”.

‘Low sensitivity’ means ‘ignore low sound’. This is confirmed. It could be the algorithm being over sensitive. We can double check it again. In the future, we can consider about calibrate mode or another way to help set sensitivity.

Thank you both for the feedback!

Same here. We have multiple Wyze cams and love them. Only the one upstairs which we use as baby monitor has the sound detection enabled. I have been playing several times with both directions low and high sensitivity and I honestly don’t see a difference at all. I tested this several times in several versions both firmware of the cameras and iOS versions, hoping an update would fix this, but since it is still an issue I am posting here.

Sorry, we haven’t made any changes on this area in the past months. In the past few months we worked on many other features and left this one untouched. The sound sensitivity has 1-100 level granularity. Does is not make a difference if you set it to 2% vs. 99%?

Hi thanks for the reply. I didn’t find a difference between 1% 5% 95% 98% or 50% In all settings it triggers when my son lets a happy scream downstairs when the door upstairs is open, or when a truck rolls bye outside. If there is a difference then it’s so subtle that I don’t see a difference.

I have the exact same problem. I can walk in the room and walk out and sometimes it detects sound. I have it set to a 1.

Hey I thought I bump this up again with the sound sensitivity. Really appreciate the help and all the cool features. Would love to see the sensitivity for sound solved though. I am using these sound notifications as sort of a baby monitor. Motion wouldn’t work here. It’s been doable since I do get notifications but like mentioned I get a lot of false alarms and fixing this would make this a lot more reliable.

Sorry, we haven’t been able to look at this issue. We have been busy with other features as you probably have seen. The earliest we can investigate is end of the month. Thanks!