Unable to fetch video from the cloud errors

I’m getting these “Failed to Fetch Video from the Cloud” errors more and more and more. Error 06, 07 and most recently 04. It was occasional when I started with Wyze cameras and the Cam Plus service in September 2020. But it’s happening more and more. It says to submit a log, but doesn’t say how. As soon as I click “ok” I’m taken back to the events list. I have acknowledged the system is kind of, “you get what you pay for”, but it’s gotten so much worse and I’m now invested with 10 cameras and still need a few more. So even low priced is expensive if it doesn’t work.


In the Wyze App:
Click Account
Wyze Support
Submit A Log

that does nothing, to be extra helpful I did that three times a day for two weeks they don’t even acknowledge it it’s still an issue. whenever I call in they just asked me to log out log back in uninstall the app reinstall the app I’ve tried it on different devices I’ve reset the device it’s clearly a firmware issue or something to do with the vdeo being uploaded corrupted


Thanks, but where do I find this “log” to submit? I can’t export one from the error message because as soon as I click “ok” I’m sent back to the events list. Typically on errors, there’s an option to export the details if the error. Also, as the person below mentioned, I’d be doing it forever. They happen so frequently. Sometimes numerous videos all in a row.

Extremely angry right now. A very important moment was missed by all 3 cameras that would have caught the event. A clear indication its a problem with your service. This is really serious. Very serious. I need these videos to “fetch from the cloud”. I’m pissed beyond belief right now. I need someone to tell me how to have these retrieved.

1 Like

If you have an sd card in the camera and it’s set on continuous record, you can either take the sd card out and look for the event or go into the app and click playback to find the event seperate from the cloud. These cameras to the best of my knowledge will continuously record even without internet access. I too have run into this error. Sometimes (I think) when you go back later the events are there, when earlier they were not.



1 Like

Don’t have an SD card in them. This is continuous. I have 4 cameras covering a particular area. I’m watching the events and as I scroll through it’s error after error after error. Also, I’m discovering sections as long as 3-4 minutes just missing in the middle of a video. I know, because I know what happened. But it shows in the time stamp too. Will go from 18 minutes to 21 minutes without missing a beat. Again, initially they worked well enough. But now that I have my 5 new V3s set up, it’s constant errors.

I don’t have the answers. I’ve noticed too that I am getting more cloud problems. Seems to happen mostly on the camera I didn’t stick a sd card in yet. I would minimally get some 16gb cards and stick them in there. You could always reset the camera and then pair it again, see if that helps. Maybe downgrade or upgrade the firmware. In the meantime stick sd card in there because any event will be viewable even if the cloud doesn’t catch it.

Thanks lionnoize. I’ve been reading on another thread that the sd card seems to be part of the problem. The sound is awful on these things anyway if you have any running background noise (TV, sound spa, fan). TV is always on with my mom (Alzheimer’s). I’ve learned to use my phone when I know we’ll be having an important conversation. But it sucks that just when I’m gonna find out what she did with something, all the cameras go on the blink at the same time. And now, noticing the missing minutes mid-video… Totally not cool.

1 Like

I am getting errors on a V2 with a card and WCOs without a card. This happened two updates ago. I’m also getting a ton of frozen video. I’ve submitted numerous reports to no avail.

1 Like

I am getting the same error that it can’t fetch the video from the cloud. I have a SD card in the camera, so why is it trying to fetch video from the cloud? And if I try to submit a log report to Wyze, I CAN’T. IT WON’T UPLOAD. I think they have a serious issue with their programming dept.
Also with EVENTS. They take way too long to show up in the app. I will get the notice on the phone. Open the app, go to EVENTS, and nothing is there!! I have to go to the camera and look at the playback.
I believe that their cloud servers are way to slow.

1 Like

EricKoehler - how do I produce a log report? In the rest of the world, a lig report is available to download from the error. I get the error, click “ok” and it takes ne back to the events list.

I purchased Cam Plus today for my WCO and the first half of the day worked great. Now it’s only error 06 and 07 for all events. I’ve removed the camera from my account and re-added it. Same issue happening. Definitely a server side issue as I’ve not received notifications either. Sometimes a 2 second clip will be saved but so far this service seems very shaky… A status.wyze.com site with updates on the service would be helpful. Right now if that service existed I’m sure it would be very red…

I have the same problem and finally chose to ignore them. The V2 is a cheap camera and you get what you pay for. We are phasing out the offending units and using another brand which seems to work really well. I am going to sell all the Wyze cameras we have and use the Reolink cameras we have purchased. I have 10 of the Wyze cameras for sale
on Craigslist now, hopefully I can unload them. Bad customer service and poor reliability on the Wyze.

Thanks for the tip on the different brand. Believe it or not, it’s the V3s I bought that are the big offenders. That said, the newer ones are in the primary areas I really need to watch. The previous V2s, the first ones I got, are set up in areas she (mom with dementia) doesn’t go much. These were my test cameras. So when those errored, and they did pretty frequently, it wasn’t as critical. Now it is. My bigger concern here now is, based on all I’m reading, I’m not confident Wyze will still be around in a year. I mean, behemoths like Xfinity and the like might get away with crappy service and even worse customer service, but a new company isn’t likely to succeed.

I’ve recently been noticing quite a few of these same errors myself when browsing through events. It seems to happen on the shorter videos (10s or less) for some reason, so I can almost tell which ones will have the issue:

I have started submitting logs and screenshots such as the one above almost every time I get the error now as it’s starting to annoy me that I’m paying for CamPlus and this has started happening daily.

I’m holding off buying Cam Plus myself until this issue gets fixed.

I per-ordered Home Monitoring Service with the kit on March 28 and have no idea when it will be shipped. Reading these comments, I am getting inclined to cancel my pre-order. I already have six of the cameras (3 indoors and 3 outdoors) and Cam Plus and by and large they are fine but I am also seeing errors 04, 06, 07 frequently. Someone wrote above that the company might not be able to survive if it doesn’t up its game and tend to agree with him. It’s a pity.

I found that my upload speed was the issue. Once I resolved that the 06 error disappeared.