Unable to delete existing rules

I have seven rules setup on my account, and I’m able to manipulate the first three with no problem, I’m also able to create new rules with no issue, however, I have four rules that I am unable to edit or delete.

When I tap and then tap a “broken” rule, it brings me to a “Create Rule” page, where everything is blank (no devices, actions, or times selected) and if I try to add a device or action I get the message “There are no devices to support the smart scenarios”.

I am able to create a rule when selecting “Create Rule” and that works just fine, I have devices, actions to pick from. For what it’s worth it may be that these broken rules were referencing a bulb that I recently had problems with and had to delete and re-add to my account.

The end result right now is - I have four rules I cannot edit or delete from my account.

1 Like

Hi, @jeff_hanley! Welcome to the community. Have you tried uninstalling/reinstalling the Wyze app lately? This is a strange behavior for rules. I haven’t experienced anything like this so far.

Thank you for the suggestion. No, I had not tried uninstalling and re-installing the app, but I just did and it did not change anything. I still have the rules I am not able to remove. For a test however, I powered up an old iphone I haven’t used in months and updated the app and am able to delete a rule using another device. I’ve only deleted one so far.

Now, directing this to the staff at Wyze, if you would like to investigate this - I live within 30 minutes of the published headquarters location in WA. I could stop by and bring the device if you wish to investigate with hands-on, and the availability to be there during typical business hours. If you want to contact me via a message on here or email.


That would be a question for @WyzeGwendolyn, I will summon them but I would not expect to hear anything until Monday.


Fair enough, and thank you. I am able to create new rules to replace the broken rules, so I’m not negatively impacted with the exception of seeing 3 rules I can’t manipulate, and I have a way to delete those from another device. At this point I’m offering in case it wants to be investigated. Thank you both @WyzeJasonJ and @StopICU33. I understand it’s a holiday / weekend, so I’ll wait until at least mid next week and if I don’t hear back I’ll likely just delete the rules from another device and move on.


Not to trump this thread, but I am having a similar issue. I posted a separate thread for it, but I cannot create new rules at this point after removing rules that I was unable to edit. Seems like you have a serious issue with the app/rules. I am running latest Android on a google pixel. I have blown away the app and restarted the phone prior to reinstalling - did not help. See this thread for similar issue:

1 Like

@WyzeGwendolyn any thoughts on this issue and is it something you’re interested in seeing in person?

Sorry for my delay! I’m going to send this over to the team now.

I haven’t seen anything on this. Where should I be looking and what’s a general timeline for a response?

@WyzeGwendolyn any update?

No, so I’m betting they aren’t needing you to come in. Did you send a log through Account > Help & Feedback > Report an Issue?

Nope. If there’s no interest in seeing the actual problem, I’ll just fix it myself with another device.

Alright, I hope your Rules are working well now. Thank you for your patience, Jeff.

Hi, I’m having the same issue as Jeff, in that I’m unable to delete a Rule. Have uninstalled app, forced stop, renamed devices, rebooted devices, logged out, etc, but nothing seems to work. I have one Rule which I’m unable to edit (so can’t get to the delete button). And based on the replies, doesn’t look like anything was resolved. Is there any way to delete a rule without having to edit it?


I am having same problem. Deleted bulb from app, and renamed and used in another area of house. The rule associated will not delete, and it keeps running turning on the light at annoying times for the current use. How can I get rid of this broken rule?? I have deleted and re-installed app and the old rule is still there. I do not see any resolution here, was it ever addressed?

1 Like

I am having the same problem. Can’t delete or edit the rule. It’s turning on one bulb in the group at a weird time despite having another rule for the note recreated bulb group. Deleted the app, reinstalled, force stopped, can’t do anything with it.

1 Like

I also have a rule that I can not access in order to edit or delete. Whenever I try to access that particular rule, the screen goes blank for a moment and returns to the Wyze home screen.

Force close, reboot phone, etc. makes no difference. Even tried this on a separate device running the Wyze app and it does exactly the same thing.

I’d be happy to simply delete the rule and create another to replace it. However, the requirement to access a corrupted and inaccessible rule, in order to delete it, doesn’t make any sense.

I wonder how wide spread this issue is, and if it’s likely to get resolved…


Same problem here too… I have one rule that I can’t access. Clicking on it restarts the app and takes me back to the main page. That last time I was successfully able to edit the rule was rather strange, it was a turn off rule, but it had a start time and end time and it gave a warning that the times overlapped. Normally a turn off rule does not have a start time.
Now it seems corrupt and inaccessible.

1 Like

I to have the same problem… any new suggestions on getting rid of it would be great. OR WYZE please look in to this big bug! This plug is technically useless now.

1 Like

I’m having a slightly similar issue. I’ve deleted a rule, but it’s still executing. It shows up in rules history that that rule was executed. Very frustrating. I have a bulb that is completely useless now until they fix this problem.

I’ve uninstalled the app reinstalled it. Changed the name of the bulb (the rule seems to be tied to the bulb itself not just the name), reset the bulb multiple times, no luck. Still waiting for tech support to get back to me.