Unable to create a rule to control plug

App problem: Created shortcut rule to turn plug off in 1 hour. Tapped the save button. Was asked if I wanted to discard the changes or cancel when I tried to leave that screen. Saw nothing that was incomplete. Tapping Save did nothing. Exited app & tested to see if the rule survived; nope! Tried again on the “create a rule” page. After creating the shortcut, ended up back on the “create a rule” page where “cancel” was the option in the upper left of the screen as opposed to a back arrow. iPhone7 (IOS 15.7.3).

I’m a newbie with poor vision, so this is really challenging. It seems to me there should be a category devoted to the app. If it exists, I could not find it. Also, the “+ Create Topic” button below is a perfectly camouflaged submit button. I thought your site was not working in Firefox but since it was the same in Chrome, I finally recognized it for what it was, despite being hidden in plain sight!

1 Like

Welcome to the Wyze User Community Forum @trudymcd! :raising_hand_man:

I see that you are creating a rule for the plug to trigger something once it has been on for one hour and one minute… But there is no Action for the plug to trigger.

The Trigger is “When This Happens”, the Action is “Do This”.

It will never save without an Action. Add the same plug as the action to “Turn Off” and it should save.


The Shortcut I’ve attempted is “Turn On” and then “Turn on for 60 minutes”. There is a green save button which activates. What I encounter differs if I click the settings icon on the device page or if I go through the Create Rule button. Once I’ve saved this the next page is the list of types of rules where “cancel” is in the upper left corner

Also, the upper part of the screen had numerous “suggestions” of things to read, or rules to try, etc. Not until I got rid of those (actually, I cannot opt out of some, only select how often they will pop up) was the Create Rule button noticeable. Like I said, I’m a newbie with poor vision.

I can understand the Turn On for 60 Minutes Shortcut Rule. However the On Rule will do the same as pressing the on button next to the plug in the Home Device List.

Shortcut Rules have Actions only. There are no triggers. It adds a button to the top row of the Home Page Device List so that when you press the button, the rule executes. Your finger is the trigger.

My shortcut buttons:

However, the images you posted above are not Shortcut Rules. Those are Trigger Rules and must have both a specified Trigger and Action.

The Plug Settings :gear: only has Schedules. These are different than Rules as they are schedules saved on the plug locally. The Schedule Rules encountered in the Create Rules interface are schedules saved on the server.

The link to Rules within the Plug Settings :gear: takes you to the same Rules List page as clicking the pencil icon :pencil2: → Edit Rules on the Home Device List or by clicking Account → Rules.

The page you posted above is the Create Rule page. The top of the page is asking what type of rule you want to create, the bottom are suggestions for pre-built template rules.

For the Trigger Rule you posted above, the one to trigger an action after the plug has been on for an hour, once you add an Action into the Action Block and save it, it will take you back to the main Rules List. Only when you click the Add + icon in the main Rules List will you be taken to the Create Rule page.

Wyze has some Knowledge Base Help Articles that may be of assistance for you:

1 Like

My actions ultimately created the button you refer to but perhaps my rules are wrong. What I want is for the plug to turn off after an hour. It doesn’t.

The button starts as it should and the timer starts but at the end of the hour the plug remains on.

I just tried to edit the rules, but the “create rules” page came up so I don’t know if the rules I’ve created exist somewhere or if each attempt erases the other. I opted for “Turn on for” 5 minutes. At the end of the 5 minutes the power remained on and the button was also still “on”. I did not observe whether the timer was running.

When I create the rule, I am able to save it. Once saved I can see that it is supposed to turn on for 60 minutes. That screen has a back arrow on top. When I tap the arrow, I’m returned to the create rule page that has the word cancel in the upper left corner.

I’m sure I must be doing something wrong but don’t know what.

You are correct. A Shortcut Rule Button cannot accomplish that. Only a Trigger Rule can.

Do this…

In the main app device list screen, click on Account. Then click on Rules.

That page will show all the rules you created. The shortcut rules are at the top, then Schedule Rules, then Device Trigger Rules.

You can delete the ones that don’t work by clicking on each and pressing delete at the bottom.

Once you have all the old rules cleared out:

  • click the plus + sign in the top right
  • Select “Device & Service Trigger”
  • Name the rule in the top entry field by clicking it and entering a rule name
  • Click Save
  • Click on the Trigger field
  • Select your plug
  • Select “Has been on for”
  • Set the duration time
  • Click save to return to the Edit Rules window
  • Click on Add Action
  • Select your plug
  • Click “Turn Off”
  • Click on Save

Do not set anything in the TIME area, this is only used to restrict the rule to operate during a specific time of day.

  • When it tells you that the trigger and action are on the same device, click proceed.

The rule has been saved.

Go back to the Home Page Device List and turn on the plug using the on\off circle next to the plug. Start timing the time. After the specified time, check to see if the plug turned off.


My screens weren’t exactly as you described but in the end I found and did exactly what you instructed and I was able to save it! Thank you so very much. It’s too late for me to check to see if it works tonight but I’ll let you know for sure tomorrow. Thanks again!


It worked! Also, from the “Using Rules in the Wyze app” page for which you provided the link, I backed up ( Wyze > Wyze App & Account > Wyze Ap) to see if I could find the info myself as I had been frustrated when searching for app help on my own. IT WAS REALLY DIFFICULT! I see that WYZE began on Kickstarter and has been developing other smart products since. I think that explains the state of the website. For knowledgeable users, especially those who’ve been with WYZE from the start, these problems may not be apparent, but for someone new to the technology and the WYZE site, it is more akin to encountering a brick wall than a doorway into the WYZE world.Thanks so much for helping me.

1 Like

So glad it is working!

The Knowledge Articles Help pages are a bit frustrating to navigate. It also changes depending you the type of device and browser you are using.

I only use my phone and always go to:


In the upper right, I click the two lines and start typing what I am looking for in the “How can we help?” Box.

The most annoying feature there is that the dang blasted Chat Bot pops up and interrupts. I just press the X to close it and continue typing my search.

You are right though, there is ample room for improvement in making the User Help area more User Helpful. I would like to see some guided tutorials for such functions.

1 Like

As I noted in my plea for help, I’m a newbie to “smart devices” and really bought the plug as a first step since getting cameras for my home (that has knob & tube wiring) will require electrical work (and I do want to get wired cams). Reviews of WYZE devices that I’ve read and also viewed on YouTube were positive. A hurdle for me is that I can only view the cams on my phone and not my desktop, so I’m still looking around. I do have a Ring Doorbell but if I try to respond to someone at the door from my desktop, their system goes nuts demanding I log in and even requiring submission of a verification code. The potential for smart devices to make it easier for me (you are responsible for my first success) is there, but many assume a user without problems. Oh, I did try the Alexa Show, hoping it would enable me to answer the door without signing in. Despite settings that were supposed to stop the ads and suggestions, they kept popping up. Out of the blue one day, in a house that was totally quiet, it began speaking and trying to engage me in a game! I returned it. I have an android tablet I’ve set up instead to help. Not ideal, but it doesn’t flash ads or talk!

I did meet the bot and tried to request app help. It is programmed to help with cams and perhaps a couple of other things and kept trying to direct me to info about them! Worthless as well as annoying. Thanks for the tip about how to search for help. I’ll keep checking back, hoping to learn that desktop access is available and, my other wish, that WYZE make smart wall outlets with usb charge slots. At this point, I’m looking at Topgreener’s product which means having to use another app. I would love to get nothing but WYZE devices. Frustrating.

Thanks again!

Many have voiced frustration over that limitation. Viewing thru the Wyze Web View website in an internet browser requires a Cam Plus subscription on cams that are compatible with Web View (not all are). And, there is no computer app. Some users have resorted to loading an Emulator program on their computer that acts like the Phone Operating System and then running the Wyze App within that.

The tablet should run the Wyze App.

Its name is Solvvy. The tech company that provides the service. I’m more of a go look for the info myself person. If I want to chat, I would much rather it have a pulse.

You are not the only one who has wished for this. It is currently a #wishlist item requested by other users. You can support the request by following the link below, voting for the request at the top, liking :heart: some posts, and adding your own reply at the bottom describing your use case.

I empathize. Wyze is my main IoT ecosystem, but I also have devices from 4 other IoT companies. There isn’t an ecosystem out there that has every device with every feature I want or need.

1 Like

I’ll definitely research Emulator programs!. There’s hope! Yeah!

As for the tablet, I have it near the door, not nearby where I could answer the door quickly, but at least I can see who’s there before I open the door. Once I have the camera Emulator program I’ll probably get rid of the Ring doorbell.

Chat bots are absolutely maddening but with some companies the bot understands when I repeatedly say I need to “talk to a real person”!

I voted for a similar listing today. It was for a wall outlet and that also had usb slots and noticed that it had been on the site since 2019 so I added a comment just in case that might serve to bump it up and catch someone’s attention.

What does “IoT” stand for? Information ___ Technology?

Decades ago I lived in Montana and have great memories of hiking and camping and catching trout that I’d wrap in foil and cook on the coals of our campfire. Never been fishing since, but, oh, how I would love to eat fresh trout again. I imagine you have lots of fish stories given your passion for fishing.

1 Like

“Internet of Things”. Another term for Smart Gadgets and the companies that make them. Wyze is an IoT Company, as is Ring and all the other competitors. It is also a term used for the market sector in which Wyze competes.

They couldn’t use “Smart Things” since that is a Trademarked brand.

1 Like

Yes. And, like most fishermen of any reputation, they are mostly exaggerated. It’s hard to get photo evidence of the one that got away. Only a colorful description will do. My focus is Crappie although I will chase a largemouth if I get the itch.


Thanks for everything!