Unable to connect remotely

I am unable to connect to Wyze V2 Cameras remotely but works perfectly fine locally. I have been searching for a solution but it seems there are other people who are also experiencing this problem. I tried multiple fixes and none seem to work. I had bought 5 more Wyze V2 Cameras and they just arrived today so I am debating if I should just return them because my other two cameras are not working remotely.

App: 1.3.152 (IOS)
Router: Ubiquiti EdgeRouter X
Access Point: UniFi AP
Download Speed: 1Gbps
Upload: 30Mbps

Tried Fixes:
Setting the IP address statically for the camera
Powering Cycling the Cameras
Power Cycling Router
VPN into my home network remotely (Worked once - But isn’t a viable solution)
Internet Speed isn’t a issue
Camera has good connection to Access Point

Are there any ports closed or redirected on your router? Here are the ports that Wyzecam needs:



I have to reserve local ip address and open/forward port for every single foscam cameras I have in order to view them remotely using tinycam pro. I don’t need to do that if I use the foscam app viewing my newer PnP foscam cameras. However I still have to do that if I want to view those PnP foscam cameras remotely using tinycam pro.

However I don’t need to do that for viewing my many Wyze cams remotely using tinycam pro. Only my Wyze account login, password and channel # need to be correct. The 1st camera in my Wyze app is channel # 1, 2nd camera channel #2 and so forth. Even I use the same or wrong local ip address it still works.

I used http://canyouseeme.org/ to check port 80, 123. They are all closed.

My understanding is PnP works with the camera’s UID, then PnP will take care of port opening and other networking stuff ?

For some odd reason it started working again, I made no changes. Hopefully it stays that way.