Remote Access [Moved]

For some reason I can no longer view my camera remotely. As long as I am connected to my local network, everything is fine. But if i’m away I can’t seem to connect to the camera. It used to work fine. As far as I know nothing has changed with my network.

Any thoughts from anyone?

Internet service issues, data cap reached?

Power cycled modem lately?

No data cap. Power cycled modem. None of my other devices, including a couple cameras of other brand have any problems. They all work fine. Just the wyzecam not working. I power cycled the camera also. No help.

I sometimes have intermittent connection issues when I’m away from home, but I have my cams plugged into a smart switch, so I can also reboot them remotely. After rebooting them, I’ve always been able to see the live feed.
Not an ideal solution, but it works for me.

The odd thing is I’ll still get alert notifications when my camera says “connection failed (-90)”, and my continuous recording doesn’t have any breaks… So not 100% sure what the mysterious -90 error is.

If you are unable to view the camera when away from home, it could be because your router is not allowing that information go outside of your home network. If you email we can try to get a bit more insight and how or where your router may be impeding the connection.

Same issue for me. Only power cycle of camera seems to clear it.

I am having the same issue. Is power cycling the only fix? Tough to do when I’m not at home. Any better solutions out there?

This is really annoying. Have 7 cameras and they each have had this problem at various time. The only time they all seem to reliably connect is while I’m attached to the home network. My other PTZ cams work just fine. I don’t have much tolerance for poor performance when it comes to things like this. Anyone had luck getting a stable remote connection?


We we are on a Apple AirPort Extreme connected to a CenturyLink DSL service via their modem.


Any advice?

I’m having the same issue. I had hoped the latest software update might help but it didn’t. Kinda ruins the need for this product without access when I’m not home.

I have also been having the same problem from the beginning and not getting any help


Ive written them and got a response that there was a trouble ticket opened but still no actual useful info I’m starting to leave negative feed on the social media sites to warn people of the poor responsiveness and general sloppy support they seem to be providing As someone previously stated, it’s a pretty useless tool if you have to be at the same location to view it. With the prices of the IP PTZ cameras coming down I foresee these will be chucked out and replaced by a camera that has functioning core capabilities. It’s a shame because I like the simplicity of the design but if it doesn’t work it’s gotta go.




Hi there! Can you let me know what your Support Ticket number is? We are a pretty small team and have been a little behind but we are actively working as hard as possible to assist. I would love to review your ticket to make sure you are getting helped in a meaningful way towards solving this issue you are having. I am one of the managers on our CS team here at Wyze Labs, Inc.

The camera should work from anywhere you are, I can view my cameras at home while I am at work for example. If that is not happening we would want to run a network test to determine where the restriction is coming from. Obviously something is blocking that data and we want to figure it out and fix it for you. I look forward to hearing from you soon, thank you so much!

Thank you for looking into this. Here is the ticket number. Please let me know what I can do to help you resolve this issue. Support Ticket #45748

I have the same issue. What is power cycling? Also, if you get a resolution from them, could you please share it here since you are the one they are talking to. Thanks

After updating my 2 wyze cams, both cams are now showing erratic speed connection. It goes from 130 kb/s down to 0 kb/s in less than 10 seconds.

Can I revert back to previous firmware? Or, is there going to be a fix to this problem?

“Power cycling” simply means removing power (unplugging) the WyzeCam for 10-15 seconds to force it to reset.

Also, see this:


In my situation they identified my problem back to my ISP. I just don’t have enough upstream bandwidth to stream HD reliably. I live in a rural area and am connected via a DSL line. I don’t think it’s 100% because of this since I have another camera that is non-WYZE that streams 1080p very reliably. Bottom line, their camera doesn’t seem to be as bandwidth efficient as some of the others, so I will be replacing these with another solution. I will continue to use them in a local (same network) to view things around the home and do time lapse videos…

My live feed started working away from my home wi-fi. This is the first day hope it continues!!!

I originally thought my phones data connection was working while I’m at home,but it never was. The only time I get live feed is when I’m on the WiFi at home. Both of my cameras do this

I have unlimited data on at&t and it’s WAY faster than my homes wifi but still no live feed. I’ve got a equally cheap momentum camera and it’ll load live feed no problem.

Hm, I’m set to SD But I wonder if it"s the same with me.