Time lapse video does not exist.

When I tap on a time lapse video to play, it says video does not exist.


I noticed that it needs to “finalize” the video after it’s stored.

From the app, when you tap the camera and go to the live stream tab, pick album. When you tap to play your time lapse video, it needs to “finalize” the clip first. Then it should start. If it says it doesn’t exist, I’d try waiting on that screen for ~1 minute (how you sometimes may need to do for Alert notification videos).

I’ve tried waiting for video to load. Still says doesn’t exist.

I’m having the same issue. I show 3 videos in the Album but all say ‘Time lapse video does not exist’.

I don’t see any way to ‘finalize’.

1 Like

The “finalize” step is nothing you have to/can do. Just in my testing, I noticed when I picked on my time lapse video for the first time there was a percentage count up. (See attached)

I’m using the Android Beta version of the app.

Another user chiming in to say I’ve got the same problem. In my case, there are four time-lapse video thumbnails showing in my album. The first three downloaded to my iPad mini just fine; the last one says it does not exist. The problematic file DOES exist in my 32GB SD card. I extracted it and it plays well in VLC. I’m running the current release firmware and iOS app.


1 Like

Has anyone found a resolution to this issue? I’m having the same issue. The first time lapse video I created worked fine, but every one since then has failed to load with the same error: “time lapse video does not exist.” I have tried creating recordings from the viewing screen, too, and those work fine. I have also confirmed that I am on the same 2.4GHz WiFi network, too.


I have a similar problem - some of my TL recordings don’t appear in the album at all. I know they were recorded, as they exist on the 32GB microSD card (and can be viewed using VLC). I’ve reported the bug to the Wyze support team, but they don’t know what’s wrong. They suggested reformatting the SD card, which of course will erase all the recordings on it.

But I’ve never encountered the problem reported by the OP (“time lapse video does not exist”).

This is using the iOS version of the Wyze app and a V2 camera.

1 Like

Last night I reformatted the SD card using the Wyze app (again) and was able to successfully take a time lapse video and then watch and download it. I left the default settings (three hours, a frame every 3 seconds).

I’m going to try a few more today to see if the problem returns.

Did anyone figure this out? I’m having the same problem with a camera I just purchased. Thanks for any help you can provide

1 Like

Same problem here, thumbnails show up in the album but I get the “time lapse video does not exist” error msg when try to play them.

1 Like

Same problem here. Recorded my first time lapse over a whole day and it tells me it doesn’t exist. Jesus this camera and its software is turning out to be a disappointment. Time to check out the return policy and maybe buy a product with some actual polish.

I was having the same issue – I reformatted the micro SD card and now it seems to be working.

I hope you all submitted tickets. (/edit - support requests) I thought I was the only one having the problem. I’m using Wyze 32Gb cards. And reformatting.
Also, I’m running 2 Android devices - An Amazon Fire 10 and a Samsung J3. The Fire 10 reports 2 files, the J3 1 file - both give me a “file does not exist” if I try to process them. This just started with the last 2 builds.

1 Like

Did it again this morning with a different cam/sd card.
Put the card in the PC, it had two directories with .h264 files, both viewable with Power Media.
I then fully formatted the card in PC.
After formatting and putting it back in the camera

This is what shows up on my Fire 10.

I’m wondering if:
When a time lapse is started it writes to the device some header files, but does not download until complete, then if for some reason putting all the stuff together fails the header files still exist on the device.

1 Like

Continued putting SD card in, checking, see videos that when clicked on say “file does not exist”.

Problem exists with all 4 of my V2 cams with SD cards.
I went through the following process on each cam with my Fire 10:
delete existing thumbnails - which when clicked on gave a message file does not exist
format the card in the cam
reboot the cam
check to see if there were any videos present - there were none
start a default time lapse, (3 hrs/3 sec) let it run for an hour or so, stop it.
Get message file saved successfully.
Attempt to access the video -get message “file does not exist”
So far tech “support” says to format the card, which I’ve done and delete and reload the app.
The app just got upgraded yesterday and I had the problem before and after upgrading the app.

Is anyone else having this problem??

Note all cams and cards were performing well a few builds ago.


When I first encountered missing TL files, I spent a lot of time trying to reverse-engineer the process. I think that when a TL specification is created, the cam writes a file named log.txt to a folder on the SDcard named time_lapse. The log,txt file contains records including BEGINTIME, ENDTIME (both in ‘Linux’ time format), TIMEGAP (in seconds), etc. Subsequently, the TL recording starts at the specified time; the log.txt file might get updated (I’m not 100% sure). When the TL recording ends, the log.txt file gets updated with a TIMEBEGIN record and an END record.

I’ve seen instances where the log.txt file was created, but no TL video was recorded. I’ve also seen instances where the log.txt file was created, the TL video was recorded successfully (filename = record.h264), but the video never appears in the Wyze Album. Since it’s not listed in the Album, it can’t be downloaded from the camera. I access those TL videos by removing the SDcard from the camera and mounting it on my MacBook.

1 Like

Yup, they are there, I’m sure

But like I wrote, the process had been working great a few builds ago.
Seems like Wyze broke something small in the upgrade.
It’s just a royal pain swapping out SD cards.

1 Like

Same issue on all my cameras

Did you submit a support request?
What OS and version are you running?