This video doesn't exist in the cloud or is still being uploaded

@rowantree & @tryme,

Thank you for bringing this to our attention and we’re sorry about the inconvenience. If you haven’t already, please reach out to our support team so they can look into this behavior at: Submit a request – Wyze.

If you already created a support ticket, please let me know the ticket numbers so I can make sure they get attention.

App reinstall solved the issue.

Same here for the past few days. All cams up to date, cache cleared. Most times the event clips will show up 20 or so minutes later. IPhone 11 Pro

1 Like

Same issue on the last 3 motion videos. Started at 6:00 pm today EST. Problem exists on my iPad and iPhone.

1 Like

The clips are being uploaded to the cloud now but it takes about 30 minutes.

1 Like

Same here. This started yesterday (or possibly the day before. My memory is a bit fuzzy) where the videos were taking 10-15 minutes to upload. Today, anything 45 minutes or newer isn’t showing. Getting the same message as the OP. I’m on an iPhone 7, have cleared the cache, removed and reinstalled the app but that hasn’t cleared it up.

1 Like


I’m having the same issue. What is the fix?


I’m having the same issues. Only one event showed up then when there is new events, when I want to review them it says This video clip doesn’t exist in teh cloud or is still being uploadated. Please try again. Then the next day the event gets removed.

That doesn’t work

Nope its 2020 and its still hapening on ios

Would you mind sending us logs from the camera which is encountering this error?

im having issues with my Pan Cam.

all my video are giving me the error code

“This video doesn’t exist in the cloud or is still being uploaded”

i have clear my data, formatted the sd card and rebooted and restored the device and still same issue.

Can you please check the app version number you’re using and let me know the firmware version for that Pan Cam?

I am having the same issue, on ipad for a motion event there is no thumbnail, you choose the event and get the message - “This video doesn’t exist in the cloud or is still being uploaded. Please try again later." This is very random, 2-3 times a day, on a v2 cam, firmware and app version - 2.10.72 . On my android phone there is no thumbnail and when you choose it the loading just spins and spins, app version 2.10.74. This is only an issue on one of two v2 cameras at a remote location I am using them at, both do have the same make sd card installed.

1 Like

I have this issue with the very first video that my camera record when I was setting it up and playing around. I’ve tried clearing the cache, I’ve reinstalled the app (iphone XR). Still stuck with a thumbnail I can’t get rid of.

If you’re getting the error message the at the video doesn’t exist in the cloud, it is unlikely that you’ll be able to recover that file by reinstalling the app or clearing the cache. That message means the file itself wasn’t uploaded properly to the cloud – this can be caused by things like connectivity, server hiccups, and firmware/app issues.

When you see this message come up, the best step would be sending us a log and bringing it to our attention here so we can follow-up to see if we can figure out why that error occurred. Unfortunately it isn’t likely that the video file was saved properly so there isn’t a workaround for recovering it. :disappointed:

Hi! I just installed our cameras today (because we have a creeper… and he came to our door again tonight after setting the cameras up). However, I’m getting this error too and can’t view any of the recordings. I’ve tried the above mentioned things… Clearing cache, uninstalling app, reinstalling, etc. I still can’t view them. What do I need to provide to Wyze to get this fixed? Thank you!!

A camera in such an important role and situation may not be the best candidate for testing beta app and firmware versions. Have you tried performing a router reset to see if that clears up the connection with both the device and our servers?

1 Like

If one of your coders wrote the script that issues the message, “This video doesn’t exist in the cloud or is still being loaded. Please try again!” then they know what generates the problem. THIS is the main problem with steaming video cameras… the purchaser of the cameras invested their hard-earned cash into cameras that are totally dependent on a third-party to function. A third-party, which so far appears to be entirely unreliable. Somebody at Wyze knows why this is happening, because they WROTE A SCRIPT THAT ISSUES A FLAG! Find that person and quit reading support scripts.

1 Like

I’m facing the same issue. Bought the camera 2 weeks ago and now I cannot view my event recordings also I do not get any notification.

Tried all the options mentioned in this forum but did not work. I’m trying to raise a ticket in the app but I keep getting the message your internet is not available when I’m connected to a working wifi connection.

Some help would be really appreciated.