Video clip doesn't exist in the cloud or is still being uploaded

For the past few days, I’m getting the following message when I try to watch an event clip:
" The video clip doesn’t exist in the cloud or is still being uploaded. Please try again later". Anyone else experiencing the same problem? Any ideas how to solve this… Thanks

A bunch of threads have been popping up about this topic recently.

It might be a combination of the latest iOS and the latest Wyze app not getting along, but I don’t have the issue yet, so best to see what others have to say:

It’s across the board… I’ve been occasionally experiencing this problem for the past few weeks on Android and iOS.

1 Like

Thanks for the correction!

Is there any chance this ties into the “scrolling through events across hour demarcations” issue?

About the only I still get this message (knock lots o’ wood) is on Android when I’m swiping through event clips.

Whenever I try to swipe across an hour boundary (from 12 sec event clips of one hour to the clips of the previous hour) I will very reliably get that message and have to back all the way back to the main screen to get the app to act normal again. In this case there is no missing clip however, it’s just a weird error. (and the time of the “missing” clip for EDT is 7:00pm)

With iOS, I have not seen this message in the latest app & firmware version (again looking for the wood pile to knock)

1 Like

iphone user, have the issue, started on Saturday.

I don’t know. I haven’t encountered that problem, but I’ll try to reproduce it later today/tonight.

Edit: Wow… good find! I just tried your scenario under Android and it consistently fails. If I view an Event from 10:01 am, then swipe to view the next prior Event @ 09:59 am, I get the “doesn’t exist or is being uploaded” error. I can back out and directly view the 09:59 am Event successfully, so this is a glaring bug. I get the error whether I swipe forward or backward across an hour boundary. Note the odd “19:00” timestamp on on the error display:

What else this may be related to, I don’t know. I’ll check this on iOS later…

Edit: Checked 3 flavors of iOS and can’t reproduce this. Looks like Android-only.

@WyzeTeam needs to look into this. It should be a simple bug fix. :+1:

1 Like


At least it’s very reliably reproducible so I’ve learned to live with it on the Android devices…

1 Like

Hey so I have noticed this issue too. It is happening on my iPhone and my girlfriend’s android so I don’t think its device specific. BUTTTTT I found a work around. Not sure if anyone having these issues have the Full Motion Capture turned on their cameras but I did not. So I did the 14 day trial on one of the cameras and now I can view the events ONLY on that camera. Its very weird, I did email customer support and have not gotten an email back from them. Hopefully this will get resolved soon

Today at 8:30 AM EST my issue resolved on IOS. All events are now showing with a video clip. Notifications are also triggering as expected.

1 Like

Glad to hear. I hope it’s resolved for everyone else as well. :+1:

Is this a problem thats still occuring? Android here. Have 4 cameras. Every one of them is syncing some clips but not others. Video clip doesnt exist in the cloud or is still being uploaded. This just started happening a day or 2 ago.

I have this issue. Not extremely often but it’s funny the most important clips to me are the ones that don’t get uploaded. I get all the useless tree branch clips uploaded but something that is actually important sometimes doesn’t get uploaded even though it has a thumbnail?? So it knows what the event was but doesn’t play it? It’s very confusing and Wyze needs to fix this


I don’t encounter the problem very often, but it still exists. Some will tell you it’s your inadequate Wi-Fi, interference or obstructions. Others will tell you it’s your SD card. I’d venture to say a server-side bug, most likely load-triggered or storage faults. Ponder the following… this is from a v2 cam with Person Detection and Continuous Recording to micro SD card enabled:

I receive a Notification for a Person Event:

I click the Event to view and it sits and spins:

The loading process times-out and the usual error is displayed:

If the video clip doesn’t exist in the cloud or is still being uploaded, how is it possible that I was notified of a Person Event to view if the server-side person detection algorithm is applied to a 12-second clip after it is received by the server? Obviously, the server received the clip… it processed the clip. Going into Playback for that cam, I can successfully view the entire clip period without interruption from the SD card, but I can’t view the cloud Event.

I’ve had to go back to my SD card via the Playback function to retrieve footage for police evidence twice now. Because I have continuous footage stored on SD for all of these occurrences, the “doesn’t exist in the cloud” problem isn’t a big deal to me. I feel confident that I can rely on the SD card. But I can see how it’s a big deal for others and feel your frustration.

1 Like