This video doesn't exist in the cloud or is still being uploaded

Hi there, I’m having issues viewing events. I can playback recordings via the “view playback” section no problem. And I can see thumbnails of all the events that have occured. But when I go to open the event, I get the message. (this video doesn’t exist in the cloud or is still being uploaded. Please try again later) But none of them work, even events that are days old. However if I do it from my wife’s phone (Pixel XL), logged in to the same account, it works no problem. I’ve tried uninstalling and reinstalling the Beta app (Pixel 2 XL), but still same result. Any ideas?


Same problem here… I would like a answer too

Try going into the app settings & clearing the cache (Account > App Settings > Cache). This will force the app to re-download any alert vids you select.


That worked for me!! Thanks!!


Don’t work :confused:

1 Like

Have you tried (after deleting the cache) to do a pull-down refresh of the Events page?

I did. It’s still not work.
I tryed to reset the camera, re-install the app. Close and reopen the motion. It’s show event…but never donwload on the cloud. So I don’t have any notification in the same time.

I just buy that thing: so all the update was done on the installation. …

I think you’ll need to submit a support request. In the app:

Account > Help & Feedback > Report an Issue

I have a ticket that was submitted for this issue on 12/11/2018 and 12/14/2018 with no response from support.

ticket #: 148585/150166

I suspect this issue has to do with the Android 8.0 implementation with my LG G6 as I can get this to work using Bluestacks and using the iPad app.

1 Like

Matt, I’ll see if I can get a Wyze employee to jump in here.

We’re so sorry about the delay! I sent you a response through our support center and I sent your ticket over to the team in charge of the area that your ticket was sorted into.

1 Like

Thank you Gwendolyn.

If I wasn’t such a huge fan of these cameras, I would have taken offense and returned them within Amazon’s warranty period.

I know specifically that it is an issue with my phone. Just wanting support to do some digging and figure out what specific feature is blocking access.

BTW, the guy that “sold” me on this has 6 cameras himself and is responsible for at least 4 other new customers in the past 2 months. :smiley:


You’re welcome!

Honestly, we totally get where you’re coming from. We appreciate your patience here and hope to earn back your trust.

Do you have a workaround in the meantime? I sincerely hope so given how long this has been. I’m honestly not sure how much help we’ll be in sorting out the feature issue.

Please thank that guy for us! :smiley:


I ended up buying SD Cards for both cameras but like I said, I can view the events from an iPad so I know it isn’t something with my account.


Happy to hear it! :slight_smile:

I get this all the time. Sometimes 2 of 3 videos will “not exist” and sometimes it’s all. Or none. I don’t think it’s an app issue, seems more like a camera problem. (I have flakey connectivity where my camera is located.)

1 Like

I am also having this problem, but the two other devices that use the same profile and camera are not having this problem. The only thing I can think of that I did that may have had an affect on the apps performance is that when I realized it was saving videos to my phone, I deleted the folder with the videos to save space. After that, this error message started popping up. Not sure if it’s connected at all, but it seems like it could be. Any help would be appreciated!

I’m also experiencing this issue on my Pixel 2 with Android 9 and would love a fix soon.

It works perfectly on my Amazon Fire Tablet 2015 (Google Play installed). I’m assuming it’s a problem with Android 9.

I have the same issue. I have a pixel also. It has never worked for me. Still in process with support to figure out why.

You got an answer out of support? My ticket has been open almost a month with no communication (outside of @WyzeGwendolyn) or movement.