Thermostat wiring issue

Uh excuse me? It says I have extra wires connected but I don’t. This is insane. When I choose to ignore this warning my heat pump does not work. I will likely be demanding a refund.

And in case you don’t believe me…

Original panel:

Welcome to the Wyze community @Cooltimes!
Make sure the wires are properly secured into the thermostat and your control board. If your thermostat still isn’t functioning properly, please contact Wyze Customer Support about this issue!
By phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT

Right but what does that have to do with the thermostat telling me there are wires connected that clearly aren’t there? Seems like buggy garbage to me.

Did you select wires that you didn’t have by accident during setup?

@Chuan may be able to answer technical questions about the thermostat.

1 Like


I am seeing that your RED wire that was connected to your R on your old t-stat is now labeled O/B? I ran through the step up using your configuration and it tells me to label R as Rc. You do look to have everything connected ok, just the labeling threw me. Its hard to tell if your RC , Y1 , O/B and G are inserted correctly. They should be pushed back like your bottom wires. your Y2 looks pushed in as well. might be the photo.

Ignore the stickers I put on them. Red is to Rc, Orange is to O/B, White is to W1, Black is to W2, Green is to G, former B is to C.

Also how any other wires are connected shouldn’t matter when it’s telling me there are wires in terminals that are CLEARLY EMPTY. The actual thermostat is either defective or it’s a bug with the system. Either way, refund time I guess.

I agree that shouldn’t matter. The app told me my system was incompatible, and the website checker says I was good to go. I reinstalled the app and let me proceed.

Another case: A friends app said his wasn’t compatible and wouldn’t work. He re-installed the app and successfully connected his t-stat with little issues after that.

So, have you tried reinstalling the app? I know it may/may not work. If you are already at the point of giving up and returning I totally understand that. Its just worth a shot if you really want it to work for you.

I’d suggest you ask support what to do, they may be able to help.

Thanks everyone I will call support. Put the old thermostat back on so I don’t freeze tonight.

Hi Cooltimes,
Our wire detection function is using the feedback signal from the HVAC control board. Sometimes the feedback signal may “trick” our wire detection module due to the interference. I noticed that you have tried to ignore/dismiss the wire detection. Could you ignore the warning and try to operate as normal? Your wiring looks correct and your system is supported.
Best regards,


Sadly it is not working. The heat pump does not work at all. The A/C works fine.

Had the same issue tonight. Had a HVAC tech (friend) help me with the install and had the exact same thing happen. Kept say wires that definitely are not connected were. Had to put my old thermostat back up. Requesting a refund as well. Bummed as I love my wyze lock and was looking forward to the thermostat.

Any resolve to this issue? I am getting the same problem, tried both thermostats that I received. Both tell me that I have wires in 3 spots that I don’t. I’ve installed many smart thermostats, never had this problem.

Hi, are you able to click “check again” to skip the wire detection? Our wire detection is helping users to confirm the connection but it could be tricked by HVAC signals, so we allow users to skip that checking step and move on to the next step.
Thank you

1 Like

If I click “Check Again”, it keeps giving me the same error and won’t let me past that screen.
If I close the Wyze app, then re-open it, I can tap on the thermostat and change settings, though nothing happens. For example, if I turn it on to Cool or Heat, it will show that for a few seconds, then go back to “OFF”. I even tried turning on Hold. The actual air conditioning system never turns on in any way.