Thermostat temp swings

That’s great … and should have a very long furnace life. Is it the original furnace?? :wink: couldn’t resist. :joy: I do appreciate all your effort to keep us on the straight an narrow. You’ve helped A LOT of people. :+1:

1 Like

I set my thermostat to heat my house to 67 degrees. It heats my house to 69 degrees, and then lets the temperature fall to 66 degrees before heating up again.
I keep my temperature behavior set at balanced. But someone said that if you set it to full comfort, it will not overshoot the heat setting.
However, when I did this, my temperature fell to 66 degrees … and stayed at that temperature for at least 45 minutes before the furnace came on again.
I have now pushed the slider to the completely opposite end – Savings – and will see how that works.

I am not able to use mine due to wild temp swings. I set it to heat to 69 and it didn’t shut off til actual temp was 73 or 74. This was measured with external thermometer next to Wyze stat. Both started at 69. External showed 74. Wyze showed 69 so the wild swings appear to be Wyze not sensing temp change as fast as it should. I have pics if it will help.

Hi I have the same issue after being on the same Honeywell thermostat version for years and I immediately noticed the difference. Thought the graphs confirmed

I hope the fix this soon as I had to replace back the Honeywell due to this swing. Thanks for sharing and confirming I am not crazy.

Thanks for sharing. I will leave here a note o found in one of a similar Threads on the Facebook Wyze Core Community forum. Supposedly Wyze is aware and already working on an update.

Heard back from Wyze yesterday. Sounds like they are going to address it in a software update. Here is the email:

"Richard (Wyze)

Jan 3, 2021, 12:40 PM PST

Hi Mark,

Thanks for updating us. I’m very glad to hear that your Thermostat runs perfectly well now. I can see that you have wanted to know how to customize the temperature difference. I’d be glad to check this one for you.

You can set the value of the minimum difference between the current temperature and set temperature before the system calls for heat or cool. A smaller difference means shorter cycle times, whereas a larger difference results in longer cycle times. By default, the differential temp is 0.5°F which means if you the heat is set to 65°F we will turn the HVAC on when the temperature falls to 64.5°F. A higher Differential Temp will help prevent unnecessary short cycles from wearing your heating/cooling system and reduce save cost.

At this time, this option is unavailable due to bugs that we are still working on. Don’t worry, we will make it available in the coming app updates 2.17+. Once available, you should see this by going to Settings > System > Differential Temp.

I hope this information finds you well and feel free to reply if I can assist you with anything else.

Thanks for being part of Wyze and stay safe!

Richard - Wyze Wizard"

1 Like

The version of the stat app that I have does not show those steps to change the temp swing.

Was the terminology just changed? Are the adjustments still there?


1 Like

This is really concerning if the default is the smallest differential. I am already seeing a 3 degree temp swing. If the next update doesn’t fix it, I might have to go back to my old thermostat that would always stay on the same temp that I set it at.

If I set it at 70, it will drop to 69 and turn on the heat pump. It will than run up to 70 degrees and at that point turn on my stage 2 electric coils and run the heat up to 72 degrees. I have no idea why it turns on the stage 2 coils when it is already at temp, but this is causing a massive increase in electricity usage.

My old thermostat would stay at 70 and only run the stage 2 if it couldn’t keep up with the demand. My heat pump could keep up a lot easier too when the old thermostat wouldn’t let it get as cold.

1 Like

They haven’t come up with the update yet. That should supposedly allow us to set it up.

I already replaced to my old Honeywell until they fix this. It makes no sense to me.

According to that email, the default is the lowest .5f differential. So unless they figure out why my stage 2 is turning on at the set temp and overheating another 2 degrees, I don’t think a setting change will fix the problem.

where did you get this charts?

I also went back to my Honeywell. If Wyze can’t or wont fix these wild temp swings, I’ll try to return mine.

I am going to try and give them some time. It should be all software/firmware fixes hopefully. If it is a hardware limitation then I might switch. They are still in the pre-order stage after all.

1 Like

There are from a “Netatmo” indoor module that is sitting in very close proximity to the thermostat.

Yes. I have 3 which I bought on preorder
I removed them and will wait until this is fixed. Like people mentioned should be a software fix. ?

Here’s my charts that confirm the +/- 0.5 degree differential (or 1 degree deadband)…gas forced air, variable fan, stage 2 controlled by furnace, high 20s outside … hanging in so far. Awaiting a humidifier and Stage 2 fix which I was told today will be in app 2.17.X and firmware coming soon…:thinking:

oh, and these were generated by Govee smart temp monitor placed next to Wyze thermostat. Set point at 69 degrees during day, 67 at night …

You are not getting the overshoot?

I wonder if they should have the setpoint at a .5 degree. So if I set it at 70, the actual internal setpoint would be 70.5. That way it would turn on at 70 and off as soon as it hits 80. Hopefully, that way it would pretty much always say 70 on the screen and cause less confusion like a normal thermostat.

1 Like

I am getting the overshoot as well and I think 0.5 to actual 1F would be ideal and standard. Or at least the option in the settings to adjust it so the user can decide.

No overshoot, but I do notice the actual temp on Wyze tstat appears to round up at 69.5 to 70 degrees. So my Wyze actual temp reading displays 68-70 while the thermometer tracks 68.4 to 69.5 … prob shouldn’t rounding up at .5 but truncate decimals til it his 70 or show decimals…