Thermostat problem

So Spectrum decided to send new equipment, which made me have to add everything single wyze product back again, not sure why. Anyways I’m trying to heat up the house and it won’t work. Mind you it has worked for the longest with no issue. Now I’m stuck at the missing xxxx wire and won’t let me through. I cant even fully delete the thermostat to start completely new now, I’ve reset the thermostat plenty of times and it just takes me back to the same point and message. What could be the issue now🤷

When you get a new router the easiest way to get everything back online quickly is to reset the new router to exactly the same SSID and Password as the old one. Then, when it reboots, all your devices will never know there is a new router and log right back in.

Unfortunately, because you have already done a reset on the T-stat, that is a moot point because it has to be reinstalled.

You are also experiencing a thermostat stuck in it’s setup routine which is difficult to get out of. There have been successful attempts to get thru that though. The last user I helped placed their phone in Airplane mode to shut off the WiFi and the Cellular Data on their phone before attempting to delete the device and then enabling the internet after it was deleted. This cuts the Wyze server out if the decision making process. This may work for you.

After that, you should be able to run a setup with the wires you have already connected.


I got out of the setup, cables are where they always where and I’m still having issues. We are currently 31° and i can’t heat the house. If i try to test the system, all i hear is clicking it may turn on for a split second but than cuts off and you hear more clicking.:person_facepalming: Everything in the app seems to be working as it should only is not doing nothing at all.

Post a snapshot of the wires plugged into the mounting plate and the wires at the unit board. I’m not a wiring expert, but it will help when someone who is takes a look at this post.

Did you install a C Adapter when you first installed the thermostat?

Do you have the original snapshots of the wiring at the mounting plate when the old thermostat was there?

To Delete the Thermostat, you can go to the Main Device Page and click on the pencil in the top right of the screen, then select Edit Devices. you will see a minus sign to the left of the T-Stat, if you tap on that it will delete it from your list of devices.

You will then need to go through the setup process again.

Which wire is it saying you are missing?

@speadie , any ideas?

That’s the current setup, it was working fine over a year so obviously there’s has been no change, except the new modem and router. Everything on the app side is setup. I even just tried emergency heat and it just blows cold air.

Also when I’m going through the setup it keeps telling the W1 is missing no matter what i do, and if it helps i I stripped the wires clean last night.

Did you inspect the back of the head unit to make sure there isn’t a damaged pin?

1 Like

I am not an HVAC person, but have set mine up as I am sure you did as well.

Have you checked your Furnace to make sure the W1 is still connected? Just trying to reason things out.

Yes they all look good and clean

I will have to check, but there shouldn’t be a reason for it to move :person_shrugging:

All of these startup warnings can be skipped, with enough retries. Eventually it will let you skip them.
Tell your wyze that your old thermostat has the following wires: Rc, Y, O, G, W, E, and C.

And in the future, If you need to manually kick on emergency heat on a heat pump with a misbehaving thermostat, you should be able to do that by connecting a jumper between Rc and W1 and G.


I got it working later that day, solution was found somewhere in the forum. Just had to move W1 (white wire over to * as show in this picture from the same post.