Thermostat not responding to set temp

Hello there,
I have a short term rental property in VT that has Wyze door lock, cameras, plugs and thermostat.
House is located 5 hours from my residence. This is our first cold season with thermostat installed.
I went to the house recently only to discover that the house was 88 degrees while the thermostat was set to 55 degrees. I reached out to tech support, awaiting answer now… since returned home.
I have been monitoring the thermostat since, The actual temp is NEVER what the set temp is. It varies from 5 - 20 degrees. I have tried turning the thermostat off, which does cool the house down (that I can tell on app), I tried “away” which worked yesterday… but not today.
Can anyone give me some advice here? Support said they are sending my issue to the development team and to look for updates to the app/devices.

Currently my house is set to OFF but is 72 degrees in the house
Earlier it was set to AWAY at 52 degrees, but was actually 74 in the house.
Thanks for any help you can provide.