Thermostat incompatible per app

Hi all, I’ve posted this question in the subReddit as well, sorry for the spaminess, just trying to get an answer by Tuesday when my HVAC crew wants to finish up…

I’m trying to set up the Wyze thermostat in my new construction house, which has a 2.5 ton Frigidaire ‘all-in-one’ outdoor unit then the air handler inside. I proceeded through the app’s setup wizard, and get a message that the thermostat is incompatible with my system. I don’t see a menu option here to add pics, so please see the Reddit thread for them:

I tried reinstalling the app since that was mentioned in other threads on this forum as solving the issue. Also tried ‘cheating’ the setup wizard questions where it asks Y/N for a heat pump (i.e. first answered Yes, then on retry as No) in case that was the hang-up (I do have a heat pump as part of the all-in-one outdoor unit, then air handler indoors). All-electric.

Wire for stat is 24VDC.

Your Reddit pics don’t show the furnace control board’s receiving connections. Without that, the thermostat’s wires are just a bunch of guesses, hoping someone followed a convention. :slight_smile:

You should be able to drag-and drop pics here, but I will alert the Mods just in case.

Hopefully, our resident expert user @speadie can offer some insights. :slight_smile:


Looks like reddit found the problem, You didn’t have the Rc wire selected as an option on the app. Also, you have Y2 selected instead of W/W1